• Carlos Garnacho's avatar
    configure: Check that sqlite3 has sqlite3_auto_extension() enabled · f3db8b28
    Carlos Garnacho authored
    Only do this if we need to load the FTS5 module, sqlite3 might have
    been compiled with SQLITE_OMIT_LOAD_EXTENSION, which will make things
    go very wrong (poking NULL vfuncs in a 0'ed out sqlite3_api_routines)
    at runtime.
    
    This facility must be enabled if we need to load our FTS module, so
    bail out at configure time if it's not there.
    f3db8b28
Name
Last commit
Last update
..
.gitignore Loading commit data...
attributes.m4 Loading commit data...
sqlite-auto-extension.m4 Loading commit data...
sqlite-builtin-fts5.m4 Loading commit data...
sqlite-threadsafe.m4 Loading commit data...
tracker.m4 Loading commit data...
vala-extra.m4 Loading commit data...