• Arfrever Frehtes Taifersar Arahesis's avatar
    Handle ICU_LIBS as LIBADD, not LDFLAGS to prevent linking errors · 1f01f49b
    Arfrever Frehtes Taifersar Arahesis authored
    For https://bugzilla.gnome.org/show_bug.cgi?id=677606
    For https://bugs.gentoo.org/show_bug.cgi?id=417539
    
    If libxml2-2.8.0 is built with --with-icu --with-python on a system that has an
    older version of libxml2 installed, then during "make install", libxml2mod.so
    gets relinked to the systemwide version of libxml2.so.2 instead of libxml2.so.2
    from the build tree, and fails at runtime if symbol versions from the older
    libxml2.so.2 are not available. This effectively makes it impossible to build a
    libxml2-2.8.0 binary package on a system that does not already have
    libxml2-2.8.0 installed.
    
    Investigation by Rafał Mużyło and Arfrever Frehtes Taifersar Arahesis revealed
    the cause of the problem to be that libxml2's configure was adding ICU_LIBS to
    LDFLAGS instead of to LIBADD. This resulted in GNU libtool using the wrong
    argument order in its relinking command that gets run during "make install".
    1f01f49b
libxml-2.0-uninstalled.pc.in 297 Bytes