• Dan Winship's avatar
    Require C90 compliance · 6e4a7fca
    Dan Winship authored
    Assume all supported platforms implement C90, and therefore they
    (correctly) implement atexit(), memmove(), setlocale(), strerror(),
    and vprintf(), and have <float.h> and <limits.h>.
    
    (Also remove the configure check testing that "do ... while (0)" works
    correctly; the non-do/while-based version of G_STMT_START and
    G_STMT_END was removed years ago, but the check remained. Also, remove
    some checks that configure.ac claimed were needed for libcharset, but
    aren't actually used.)
    
    Note that removing the g_memmove() function is not an ABI break even
    on systems where g_memmove() was previously not a macro, because it
    was never marked GLIB_AVAILABLE_IN_ALL or listed in glib.symbols, so
    it would have been glib-internal since 2004.
    
    https://bugzilla.gnome.org/show_bug.cgi?id=710519
    6e4a7fca
garray.c 47.3 KB