vimeo: remove due API change v2->v3

This is not working for over a year now.
Related: GNOME/grilo-plugins#67
1 job for disable-plugins in 4 minutes and 9 seconds