Commit be95204c authored by J.H.M. Dassen (Ray)'s avatar J.H.M. Dassen (Ray)

Updated debianisation

parent 9356fbb4
gnumeric (1.6.3-1) unstable; urgency=medium
* New upstream release.
* [debian/rules] Corrected sed expression to determine the upstream
version: `+' is allowed in a debian_revision. This fixes the
dependencies when a binNMU is made of this package. (Closes: #357936)
* [debian/control] Updated goffice build dependency per configure.in .
Updated pxlib-dev and libgsf-1-dev build dependencies to ensure only one
version of libgsf is used.
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Thu, 23 Mar 2006 08:36:14 +0100
gnumeric (1.6.2-3) unstable; urgency=medium
* [ChangeLog, NEWS, README, plugins/fn-financial/functions.c,
......
......@@ -4,8 +4,8 @@ Priority: optional
Maintainer: J.H.M. Dassen (Ray) <jdassen@debian.org>
Build-Depends: debhelper (>= 4.2.21), dh-buildinfo, po-debconf,
gettext, bison, flex, scrollkeeper, libxml-parser-perl,
zlib1g-dev, libglib2.0-dev (>= 2.6.0), libgsf-1-dev (>= 1.13.2),
libgoffice-1-dev (>= 0.2.0), libxml2-dev (>= 2.6.10-2),
zlib1g-dev, libglib2.0-dev (>= 2.6.0), libgsf-1-dev (>= 1.14.0-1),
libgoffice-1-dev (>= 0.2.1), libxml2-dev (>= 2.6.10-2),
libpango1.0-dev (>= 1.8.1),
libgtk2.0-dev (>= 2.6.0), libglade2-dev (>= 1:2.4.0-1),
libgnomeprint2.2-dev (>= 2.8.2), libgnomeprintui2.2-dev (>= 2.8.2),
......@@ -14,7 +14,7 @@ Build-Depends: debhelper (>= 4.2.21), dh-buildinfo, po-debconf,
libbonoboui2-dev (>= 2.6.1-1),
libgnome2-dev (>= 2.4.0-2), libgnomeui-dev (>= 2.4.0-2),
libgsf-gnome-1-dev (>= 1.13.2),
pxlib-dev (>= 0.5.1-2), libperl-dev,
pxlib-dev (>= 0.5.1-2+b1), libperl-dev,
python2.3-dev, python-gtk2-dev
Standards-Version: 3.6.1
......
......@@ -24,7 +24,7 @@ export INSTALL=/usr/bin/install -p
# Are we building a release version, or are we doing development?
CVS_BUILD=$(shell test ! -d CVS; echo $$?)
upstreamversion=$(shell dpkg-parsechangelog | grep Version | head -1 | sed -e 's/Version: //g' -e 's/-[A-Za-z0-9\.]*$$//g')
upstreamversion=$(shell dpkg-parsechangelog | grep Version | head -1 | sed -e 's/Version: //g' -e 's/-[A-Za-z0-9+\.]*$$//g')
# Features configuration
# ----------------------
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment