Commit 4c5f3e19 authored by J.H.M. Dassen (Ray)'s avatar J.H.M. Dassen (Ray)
Browse files

Updated debianisation

parent 3c96d0aa
gnumeric (1.6.2-2) UNRELEASED; urgency=low
* [debian/control, debian/rules] Don't try to build the gda and gnome-db
plugins and dropped dependencies on and references to them - they need
newer packages than are available in sid and there are no signs sid will
get these any time soon.
* [debian/po/da.po] Added, courtesy of Claus Hindsgaul <claus_h@image.dk>.
(Closes: #352689)
* [debian/po/cs.po] Added, courtesy of Miroslav Kure
<kurem@upcase.inf.upol.cz> (Closes: #353370)
<kurem@upcase.inf.upol.cz>. (Closes: #353370)
* [debian/po/sv.po] Added, courtesy of Daniel Nylander
<yeager@lidkoping.net> (Closes: #353786)
<yeager@lidkoping.net>. (Closes: #353786)
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Fri, 10 Feb 2006 21:29:05 +0100
......
......@@ -14,7 +14,6 @@ Build-Depends: debhelper (>= 4.2.21), dh-buildinfo, po-debconf,
libbonoboui2-dev (>= 2.6.1-1),
libgnome2-dev (>= 2.4.0-2), libgnomeui-dev (>= 2.4.0-2),
libgsf-gnome-1-dev (>= 1.13.2),
libgda2-dev (>= 1.0.4-1), libgnomedb2-dev (>= 1.0.4-7),
pxlib-dev (>= 0.5.1-2), libperl-dev,
python2.3-dev, python-gtk2-dev
Standards-Version: 3.6.1
......@@ -90,5 +89,3 @@ Description: additional plugins for the GNOME spreadsheet
o The Python plugin loader
o Additional Python functions
o The Gnome glossary
o The gda (Gnome Database Access) plugin
o The GNOME-DB plugin
......@@ -34,30 +34,15 @@ upstreamversion=$(shell dpkg-parsechangelog | grep Version | head -1 | sed -e 's
features:=
# The Python executable
features+= PYTHON=/usr/bin/python
# The Python support offers a nice way to extend gnumeric's functionality.
features+= --with-python
# Bonobo allows us to use parts of other applications as components via
# CORBA, and was supposed to allow us to work as a component for other
# applications. However, that promise hasn't really been realised and
# according to Morten Welinder "drop bonobo from your build. it's
# pointless."
features+= --without-bonobo
# Plugin to access databases through the GDA framework.
features+= --with-gda
# Guile offers an additional way to extension gnumeric, but the guile
# support is for guile 1.5 or newer, which is not currently available in
# Debian.
# Spreadsheet indexer for beagle
features+= --enable-ssindex
features+= --without-guile
# Plugins to access databases through the GDA framework and through GnomeDB.
#
# The GDA and GnomeDB plugins for gnumeric now require versions of GDA and
# GnomeDB that are not available as packages yet.
# Mon, 10 Oct 2005 20:37:06 +0200
features+= --without-gda --without-gnomedb
# configure.in: "Gnome Basic is extremely API unstable; it is likely that
# gnumeric will only build with the single version mentioned in
......@@ -66,11 +51,6 @@ features+= --without-guile
features+= --without-gb
# The GDA and GnomeDB plugins for gnumeric now require versions of GDA and
# GnomeDB that are not available as packages yet.
# Mon, 10 Oct 2005 20:37:06 +0200
features+= --without-gda --without-gnomedb
# Debian's psiconv packages are not recent enough for gnumeric; see
# http://bugs.debian.org/268576
# Tue, 9 Aug 2005 17:36:09 +0200
......@@ -79,8 +59,23 @@ features+= --without-psiconv
# Paradox database files plugin
features+= --with-paradox
# Spreadsheet indexer for beagle
features+= --enable-ssindex
# Perl plugin
features+= --with-perl
# The Python executable
features+= PYTHON=/usr/bin/python
# The Python support offers a nice way to extend gnumeric's functionality.
features+= --with-python
# Bonobo allows us to use parts of other applications as components via
# CORBA, and was supposed to allow us to work as a component for other
# applications. However, that promise hasn't really been realised and
# according to Morten Welinder "drop bonobo from your build. it's
# pointless."
features+= --without-bonobo
confflags := --prefix=/usr \
--mandir=\$${prefix}/share/man \
......@@ -96,7 +91,7 @@ else
confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
endif
# Make the linker work a bit harder so dynamic loading can be done faster
# Make the linker work a bit harder so dynamic loading can be done faster.
#
# Make the linker only include actual dependencies on libraries, rather than
# for all libraries specified in the link line.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment