Remove expected error, which makes geary crash as it was fixed

This bug does not occur with libhandy 1.0.3-2 (Debian testing). It depends
on libhandy#305 which was fixed in October 2020
(and thus before the release of libhandy 1.0.1). When using a newer libhandy
it now issues a critical debug log and coredumps, making geary non-functional.

Fixes: GNOME/geary#1175
3 jobs for issues_421 in 27 minutes and 31 seconds
latest
Status Job ID Name Coverage
  Build
passed #1211811
fedora

00:04:22

passed #1211812
ubuntu

00:04:22

 
  Test
passed #1211813
flatpak
flatpak

00:23:08