Commit 8a688f12 authored by Matthias Clasen's avatar Matthias Clasen Committed by Matthias Clasen

Use PKG_PROG_PKG_CONFIG. (#392636, Yevgen Muntyan)

2007-01-07  Matthias Clasen  <mclasen@redhat.com>

        * m4macros/glib-2.0.m4: Use PKG_PROG_PKG_CONFIG.  (#392636,
        Yevgen Muntyan)



svn path=/trunk/; revision=5225
parent bb551b0c
2007-01-07 Matthias Clasen <mclasen@redhat.com>
* m4macros/glib-2.0.m4: Use PKG_PROG_PKG_CONFIG. (#392636,
Yevgen Muntyan)
2007-01-07 Tor Lillqvist <tml@novell.com> 2007-01-07 Tor Lillqvist <tml@novell.com>
* glib/giowin32.c: Handle GIOChannels for file descriptors * glib/giowin32.c: Handle GIOChannels for file descriptors
......
...@@ -31,20 +31,13 @@ AC_ARG_ENABLE(glibtest, [ --disable-glibtest do not try to compile and run ...@@ -31,20 +31,13 @@ AC_ARG_ENABLE(glibtest, [ --disable-glibtest do not try to compile and run
esac esac
done done
AC_PATH_PROG(PKG_CONFIG, pkg-config, no) PKG_PROG_PKG_CONFIG([0.7])
no_glib="" no_glib=""
if test x$PKG_CONFIG != xno ; then if test "x$PKG_CONFIG" = x ; then
if $PKG_CONFIG --atleast-pkgconfig-version 0.7 ; then
:
else
echo *** pkg-config too old; version 0.7 or better required.
no_glib=yes
PKG_CONFIG=no
fi
else
no_glib=yes no_glib=yes
PKG_CONFIG=no
fi fi
min_glib_version=ifelse([$1], ,2.0.0,$1) min_glib_version=ifelse([$1], ,2.0.0,$1)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment