Commit c1dbf80d authored by Emmanuele Bassi's avatar Emmanuele Bassi

Make the X11 dependency less automagic

If the x11 option is enabled then we require X11.

We should use a `dependency()` object in order to check for Xlib,
instead of checking for libX11 being available.

Closes #77
parent 11a1961b
......@@ -381,10 +381,8 @@ subdir('gdk-pixbuf')
gdkpixbuf_xlib_inc = []
if get_option('x11')
x11_dep = cc.find_library('X11', required: false)
if x11_dep.found()
subdir('contrib/gdk-pixbuf-xlib')
endif
x11_dep = dependency('x11')
subdir('contrib/gdk-pixbuf-xlib')
endif
# i18n
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment