Commit ef01d1fb authored by Milan Crha's avatar Milan Crha

Extend error messages in FindLDAP.cmake

parent b9f05e5c
......@@ -80,7 +80,7 @@ if(WITH_OPENLDAP)
#endif
return 0; }" openldap_2_x)
if(NOT openldap_2_x)
message(FATAL_ERROR "At least 2.0 OpenLDAP version required")
message(FATAL_ERROR "At least 2.0 OpenLDAP version required; either use -DWITH_OPENLDAP=OFF argument to cmake command to disable LDAP support, or install OpenLDAP")
endif(NOT openldap_2_x)
else(WITH_OPENLDAP)
CHECK_C_SOURCE_COMPILES("#include \"ldap.h\"
......@@ -90,7 +90,7 @@ else(WITH_OPENLDAP)
#endif
return 0; }" sunldap_2_x)
if(NOT sunldap_2_x)
message(FATAL_ERROR "At least 2.0 SunLDAP version required")
message(FATAL_ERROR "At least 2.0 SunLDAP version required; either use -DWITH_SUNLDAP=OFF argument to cmake command to disable LDAP support, or install SunLDAP")
endif(NOT sunldap_2_x)
endif(WITH_OPENLDAP)
......@@ -121,9 +121,9 @@ if(libldap_provides_ldap_open)
endif(WITH_STATIC_LDAP)
else(libldap_provides_ldap_open)
if(WITH_OPENLDAP)
message(FATAL_ERROR "Could not find OpenLDAP libraries")
message(FATAL_ERROR "Could not find OpenLDAP libraries; either use -DWITH_OPENLDAP=OFF argument to cmake command to disable LDAP support, or install OpenLDAP")
else(WITH_OPENLDAP)
message(FATAL_ERROR "Could not find SunLDAP libraries")
message(FATAL_ERROR "Could not find SunLDAP libraries; either use -DWITH_SUNLDAP=OFF argument to cmake command to disable LDAP support, or install SunLDAP")
endif(WITH_OPENLDAP)
endif(libldap_provides_ldap_open)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment