Commit 3db8a6c5 authored by Michael Mera's avatar Michael Mera
Browse files

meson-templates: Fix deprecation warning in Python templates

Since meson 0.55.0, external_program.path() as been replaced by
external_program.full_path(). The projects initialized from these
templates require at least meson 0.59.0, so this fixes the corresponding
deprecation warning.
parent 1777a097
Pipeline #408098 failed with stage
in 60 minutes and 25 seconds
......@@ -4,7 +4,7 @@ moduledir = join_paths(pkgdatadir, '{{name_}}')
python = import('python')
conf = configuration_data()
conf.set('PYTHON', python.find_installation('python3').path())
conf.set('PYTHON', python.find_installation('python3').full_path())
conf.set('pkgdatadir', pkgdatadir)
configure_file(
......
......@@ -12,7 +12,7 @@ gnome.compile_resources('{{name}}',
python = import('python')
conf = configuration_data()
conf.set('PYTHON', python.find_installation('python3').path())
conf.set('PYTHON', python.find_installation('python3').full_path())
conf.set('VERSION', meson.project_version())
conf.set('localedir', join_paths(get_option('prefix'), get_option('localedir')))
conf.set('pkgdatadir', pkgdatadir)
......
......@@ -12,7 +12,7 @@ gnome.compile_resources('{{name}}',
python = import('python')
conf = configuration_data()
conf.set('PYTHON', python.find_installation('python3').path())
conf.set('PYTHON', python.find_installation('python3').full_path())
conf.set('VERSION', meson.project_version())
conf.set('localedir', join_paths(get_option('prefix'), get_option('localedir')))
conf.set('pkgdatadir', pkgdatadir)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment