eula-dialog: show EULA when specific packages require so

Previously, if an update is avialable for packages which requires EULA
confirmation, you cannot download the update as there is no klass
support for eula_question. This makes GNOME Software unable to update
the system in such a scenario.

Fix that by creating a new class named GsTask deriving from PkTask and
implementing the eula_question virtual method.

GNOME/gnome-software#702
1 job for eula-dialog in 15 minutes and 54 seconds (queued for 1 second)
latest
Status Job ID Name Coverage
  Build
passed #522222
build-gnome-software

00:15:54