build: Require libgit2-glib >= 1.1.0

GGIT_STATUS_WORKING_TREE_UNREADABLE was introduced in this version
1 job for bump-glib in 47 minutes and 4 seconds