Commit a5e6f27d authored by Christian Hergert's avatar Christian Hergert

gui: require WebKit2 at plugin initialization time

This ensures we have the appropriate version before plugins call into any
gi loading.
parent 2852c6aa
......@@ -366,6 +366,7 @@ _ide_application_load_plugins (IdeApplication *self)
!g_irepository_require (NULL, "Dazzle", "1.0", 0, &error) ||
!g_irepository_require (NULL, "Jsonrpc", "1.0", 0, &error) ||
!g_irepository_require (NULL, "Template", "1.0", 0, &error) ||
!g_irepository_require (NULL, "WebKit2", "4.0", 0, &error) ||
!g_irepository_require (NULL, "Ide", PACKAGE_ABI_S, 0, &error))
g_critical ("Cannot enable Python 3 plugins: %s", error->message);
else
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment