Commit 0c72d97c authored by Christian Hergert's avatar Christian Hergert

release 3.29.1

parent be56234b
......@@ -33,11 +33,18 @@ Changes since last release:
• Many API improvements to simplify access from language bindings.
• Flatpak "simple" build systems now run the commands from the srcdir
matching more closely to what flatpak-builder will do.
• XML plugin improvements for performance and stability.
• XML plugin improvements for performance, stability and DTD tracking.
• GDB integration now properly updates frames for the selected thread.
• Various terminal improvements.
• Various memory leak fixes.
• The build manager tries to avoid reseting the build pipeline in
certain situations.
• Support for rofiles-fuse has been added to speed up flatpak cachepoint
generation.
• Improvements to build flag parsing across entire directories.
Updated Translations:
Swedish, Indonesian, Lithuanian, Dutch, Czech, Italian,
Brazilian Portuguese, Latvian
Swedish, Indonesian, Lithuanian, Dutch, Czech, Italian, Brazilian
Portuguese, Latvian, Hungarian, British English, German
......@@ -81,6 +81,20 @@
<translation type="gettext">gnome-builder</translation>
<releases>
<release version="3.29.1" date="2018-04-16">
<description>
<p>
Builder 3.29.1 is our first development release towards 3.29.1.
This mostly includes non-visible changes such as a new thread pool and code-indexer APIs.
</p>
<ul>
<li>A new "Runtime Terminal" option has been added to get a terminal in the same environment as running the application. Contrast this to a "Build Terminal" which is the build environment.</li>
<li>A new sysroot plugin to work alternative install roots.</li>
<li>Many improvements to plugins.</li>
<li>Various performance improvements and memory leak fixes.</li>
</ul>
</description>
</release>
<release version="3.28.0" date="2018-03-13">
<description>
......
project('gnome-builder', 'c',
license: 'GPL3+',
version: '3.29.0',
version: '3.29.1',
meson_version: '>= 0.44.0',
default_options: [ 'c_std=gnu11',
'cpp_std=c++11',
......@@ -213,7 +213,7 @@ ld_supports_version_script = cc.links('''
message('Linker supports --version-script: @0@'.format(ld_supports_version_script))
# Commonly used deps
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.28.0')
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.29.1')
libgio_dep = dependency('gio-2.0', version: '>= 2.56.0')
libgiounix_dep = dependency('gio-unix-2.0')
libgtk_dep = dependency('gtk+-3.0', version: '>= 3.22.26')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment