loaders: Make the names of prepared_func and updated_func consistent

They were prepare_func/prepared_func, and update_func/updated_func in
various places.

Since their corresponding type names are GdkPixbufModulePreparedFunc
and GdkPixbufModuleUpdatedFunc, make all the fields be called
prepared_func and updated_func to make them easier to grep.
Status Job ID Name Coverage
  Build
passed #428546
meson-fedora-x86_64

00:05:58

passed #428547
win32
msys2-mingw64

00:05:19