Require Rust 1.26

parent 25cf1d8b
......@@ -12,8 +12,6 @@ variables:
I386_DEBIAN_TESTING: "registry.gitlab.gnome.org/gnome/librsvg-oci-images/i386/debian:testing"
I386_UBUNTU_BIONIC: "registry.gitlab.gnome.org/gnome/librsvg-oci-images/i386/ubuntu:18.04"
RUSTC_1_24: "registry.gitlab.gnome.org/gnome/librsvg-oci-images/rustc:1.24"
RUSTC_1_25: "registry.gitlab.gnome.org/gnome/librsvg-oci-images/rustc:1.25"
RUSTC_1_26: "registry.gitlab.gnome.org/gnome/librsvg-oci-images/rustc:1.26"
RUSTFMT_NIGHTLY: "registry.gitlab.com/alatiera/rustfmt-oci-image/rustfmt:nightly"
......@@ -207,20 +205,6 @@ debian:testing_release_i386:
# STAGE 3 RUSTC TESTS
#######################################################################
rustc:1_24:
image: $RUSTC_1_24
variables:
LIBRSVG_DEBUG: "yes"
<<: *rustc
<<: *stage_3
rustc:1_25:
image: $RUSTC_1_25
variables:
LIBRSVG_DEBUG: "yes"
<<: *rustc
<<: *stage_3
rustc:1_26:
image: $RUSTC_1_26
variables:
......
......@@ -31,7 +31,7 @@ minimum version is listed here; you may use a newer version instead.
**Compilers:**
* a C compiler and `make` tool; we recommend GNU `make`.
* rust 1.24 or later
* rust 1.26 or later
* cargo
**Mandatory dependencies:**
......
......@@ -86,7 +86,7 @@ AS_IF(test x$RUSTC = xno,
dnl Minimum version of rustc that we support
dnl If you change this, please update COMPILING.md
MINIMUM_RUST_MAJOR=1
MINIMUM_RUST_MINOR=24
MINIMUM_RUST_MINOR=26
rust_version=`rustc --version`
version=`echo "$rust_version" | sed -e 's/^rustc //g'`
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment