Commit e6b8b102 authored by Colin Walters's avatar Colin Walters
Browse files

Revision: rhythmbox-devel@gnome.org--2004/rhythmbox--main--0.7--patch-223

fix sample pipeline in README, remove checks for 0.7 in configure
parent bcb2744f
......@@ -44,7 +44,7 @@ In the bug report please include:
* Before you report a bug, it will be useful to know if GStreamer works.
Try running this command:
$ gst-launch gnomevfssrc location=/path/to/my/musicfile.ogg ! spider ! volume ! audioscale ! audioconvert ! $(gconftool-2 -g /system/gstreamer/default/audiosink)
$ gst-launch gnomevfssrc location=/path/to/my/musicfile.ogg ! spider ! volume ! audioscale ! audioconvert ! $(gconftool-2 -g /system/gstreamer/0.8/default/audiosink)
Just replace /path/to/my/musicfile.ogg with some sound file.
You might also want to try the monkey-media tests/test-cmdline program.
......
......@@ -141,18 +141,6 @@ else if test "x$with_player" = "xgstreamer"; then
gstreamer-control-$GST_MAJORMINOR >= $GST_REQUIRED_VERSION gstreamer-gconf-$GST_MAJORMINOR >= $GST_REQUIRED_VERSION,
HAVE_SOUNDSYSTEM=yes,HAVE_SOUNDSYSTEM=no)
dnl try 0.7
if test x"$HAVE_SOUNDSYSTEM" = xno; then
AC_MSG_WARN([Couldn't find GStreamer 0.8, trying 0.7])
GST_MAJORMINOR=0.7
GST_REQUIRED_VERSION=0.7.4
PKG_CHECK_MODULES(SOUNDSYSTEM, \
gstreamer-$GST_MAJORMINOR >= $GST_REQUIRED_VERSION gstreamer-libs-$GST_MAJORMINOR >= $GST_REQUIRED_VERSION
gstreamer-control-$GST_MAJORMINOR >= $GST_REQUIRED_VERSION gstreamer-gconf-$GST_MAJORMINOR >= $GST_REQUIRED_VERSION,
HAVE_SOUNDSYSTEM=yes,HAVE_SOUNDSYSTEM=no)
fi
dnl Give error and exit if we don't have gstreamer
if test "x$HAVE_SOUNDSYSTEM" = "xno"; then
AC_MSG_ERROR([GStreamer not found, or older than version $GST_REQUIRED_VERSION])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment