Commit f31634a6 authored by Sophie Herold's avatar Sophie Herold
Browse files

Update README.md

parent 927c8155
Pipeline #208331 passed with stage
in 18 minutes and 41 seconds
# Pika Backup # Pika Backup
<p> Doing backups the easy way. Plugin your USB drive and let the Pika do the rest for you.
Doing backups the easy way. Plugin your USB drive and let the Pika do the rest for you.
</p> [<img width='240' alt='Download on Flathub' src='https://flathub.org/assets/badges/flathub-badge-en.png' />](https://flathub.org/apps/details/org.gnome.World.PikaBackup)
<p><b>Features</b></p>
<ul> ### Features
<ul>
<li>Setup new backup repositories or uses existing ones</li> <li>Setup new backup repositories or uses existing ones</li>
<li>Create backups locally and remote</li> <li>Create backups locally and remote</li>
<li>Save time and disk space because Pika Backup does not need to copy known data again</li> <li>Save time and disk space because Pika Backup does not need to copy known data again</li>
...@@ -12,29 +14,27 @@ ...@@ -12,29 +14,27 @@
<li>List created archives and browse through their contents</li> <li>List created archives and browse through their contents</li>
<li>Recover files or folders via your file browser</li> <li>Recover files or folders via your file browser</li>
</ul> </ul>
<p>
Pika Backup is powered by the well-tested borg-backup software. Pika Backup is powered by the well-tested borg-backup software.
</p>
<p><b>Limitations</b></p> ### Limitations
<p>
Currently, scheduled backups support are not supported. Excluding files from a backup via regular expressions and alike is not implemented yet. Remote backup locations must support SSH and need to have a borg-backup binary installed. Currently, scheduled backups are not supported. Excluding files from a backup via regular expressions and alike is not implemented yet. Remote backup locations must support SSH and need to have a borg-backup binary installed.
</p>
![Pika Backup Setup](/uploads/596347a2e99be37c3f8a035b75cea8ea/pika-pile-1.png) ![Pika Backup Setup](/uploads/596347a2e99be37c3f8a035b75cea8ea/pika-pile-1.png)
### Alternative software
- [Vorta](https://flathub.org/apps/details/com.borgbase.Vorta), borg-backup as backend, supports scheduled backups, Qt frontend for advanced users
- [Déjà Dup Backups](https://flathub.org/apps/details/org.gnome.DejaDup), duplicity (librsync) as backend, supports scheduled backups, GTK frontend
## Build ## Build
You need [Rust](https://rustup.rs/) to build Pika You need [Rust](https://rustup.rs/) to build Pika
```sh ```sh
$ apt install libgtk-3-dev $ apt install libgtk-3-dev
$ cargo run --release $ cargo run
```
or you can use flatpak
```sh
$ ./build-aux/flatpak-build.bash
``` ```
**Debug** **Debug**
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment