Commit 65b1d237 authored by Sam Thursfield's avatar Sam Thursfield

build: libtracker-miners-common should be a static library

This library is API-unstable helper code. In the Autotools build system
we only linked to it statically and didn't install it.

Fixes a regression introduced in 8c1ff9cf, where we stopped installing
the library but didn't make it static, which totally broke installed
versions of Tracker.
parent 6055f5ed
......@@ -29,7 +29,7 @@ if libseccomp.found()
endif
libtracker_miners_common = library('tracker-miners-common',
libtracker_miners_common = static_library('tracker-miners-common',
tracker_miners_common_sources,
dependencies: tracker_miners_common_dependencies + tracker_miners_common_private_dependencies,
c_args: tracker_c_args,
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment