Commit f7f1dabd authored by Matthias Clasen's avatar Matthias Clasen

Bug 511163 – Remove pango_extents_to_pixels() calls

        * gtk/gtkcellrenderertext.c (get_size): Use
        pango_layout_get_pixel_extents.

        * configure.in: Bump Pango requirement to 1.20

        * INSTALL.in: Update required versions


svn path=/trunk/; revision=20171
parent 9ec6a659
2008-05-26 Matthias Clasen <mclasen@redhat.com>
Bug 511163 – Remove pango_extents_to_pixels() calls
* gtk/gtkcellrenderertext.c (get_size): Use
pango_layout_get_pixel_extents.
* configure.in: Bump Pango requirement to 1.20
* INSTALL.in: Update required versions
2008-05-26 Matthias Clasen <mclasen@redhat.com>
Bug 513811 – Use cairo_format_stride_for_width()
......
......@@ -5,7 +5,7 @@ GTK+ requires the following packages:
- The GLib, Pango, ATK and cairo libraries, available at the same
location as GTK+. GTK+ @GTK_VERSION@ requires at least GLib 2.15.0,
Pango 1.19.3, ATK 1.13.0 and cairo 1.6.0.
Pango 1.20, ATK 1.13.0 and cairo 1.6.0.
- The TIFF, PNG, and JPEG image loading libraries. You most
likely have these installed on your system already. If not
......
......@@ -32,7 +32,7 @@ m4_define([gtk_binary_version], [2.10.0])
# required versions of other packages
m4_define([glib_required_version], [2.15.0])
m4_define([pango_required_version], [1.19.3])
m4_define([pango_required_version], [1.20])
m4_define([atk_required_version], [1.13.0])
m4_define([cairo_required_version], [1.6])
......
......@@ -1539,8 +1539,7 @@ get_size (GtkCellRenderer *cell,
else
layout = get_layout (celltext, widget, FALSE, 0);
pango_layout_get_extents (layout, NULL, &rect);
pango_extents_to_pixels (&rect, NULL);
pango_layout_get_pixel_extents (layout, NULL, &rect);
if (height)
*height = cell->ypad * 2 + rect.height;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment