Commit 227fc807 authored by Maciej (Matthew) Piechotka's avatar Maciej (Matthew) Piechotka
Browse files

Update gladeui for glade 4.0 (3.9.x)

parent 63f2327d
......@@ -57,6 +57,7 @@ case "$with_gtk" in
VTE_SEAL_CFLAGS=
GTK_API_VERSION=2.0
GTK_REQUIRED=2.20.0
GLADE_API_VERSION=1.0
;;
3.0) VTE_API_VERSION=2.90
VTE_API_MAJOR_VERSION=2
......@@ -66,6 +67,7 @@ case "$with_gtk" in
VTE_SEAL_CFLAGS="-DVTE_SEAL_ENABLE"
GTK_API_VERSION=3.0
GTK_REQUIRED=3.0.0
GLADE_API_VERSION=2.0
;;
esac
......@@ -540,12 +542,12 @@ AC_ARG_ENABLE([glade-catalogue],
AC_MSG_RESULT([$enable_glade_catalogue])
if test "$enable_glade_catalogue" = "yes"; then
GLADE_CATALOGUE_DIR="$($PKG_CONFIG --variable=catalogdir gladeui-1.0)"
GLADE_ICON_DIR="$($PKG_CONFIG --variable=pixmapdir gladeui-1.0)"
GLADE_MODULE_DIR="$($PKG_CONFIG --variable=moduledir gladeui-1.0)"
GLADE_CATALOGUE_DIR="$($PKG_CONFIG --variable=catalogdir gladeui-$GLADE_API_VERSION)"
GLADE_ICON_DIR="$($PKG_CONFIG --variable=pixmapdir gladeui-$GLADE_API_VERSION)"
GLADE_MODULE_DIR="$($PKG_CONFIG --variable=moduledir gladeui-$GLADE_API_VERSION)"
if test -z "$GLADE_CATALOGUE_DIR" -o -z "$GLADE_MODULE_DIR"; then
AC_MSG_ERROR([gladeui-1.0 not found])
AC_MSG_ERROR([gladeui-$GLADE_API_VERSION not found])
fi
AC_SUBST([GLADE_CATALOGUE_DIR])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment