Commit d9971e23 authored by Evan Nemerson's avatar Evan Nemerson

Add webkit2gtk-3.0 and webkit2gtk-web-extension-3.0 bindings.

Fixes bug 676249.
parent af154d0f
......@@ -284,6 +284,10 @@ dist_vapi_DATA = \
vte-2.90.vapi \
webkit-1.0.deps \
webkit-1.0.vapi \
webkit2gtk-3.0.vapi \
webkit2gtk-3.0.deps \
webkit2gtk-web-extension-3.0.vapi \
webkit2gtk-web-extension-3.0.deps \
x11.vapi \
xcb.vapi \
xcb-icccm.vapi \
......@@ -409,6 +413,7 @@ GIR_BINDINGS = \
rest-0.7 \
udisks2 \
vte-2.90 \
webkit-1.0 \
$(GSTREAMER_1_0_BINDINGS) \
$(NULL)
......@@ -755,3 +760,10 @@ vte-2.90:
webkit-1.0:
$(GENVAPI) --library $(srcdir)/webkit-1.0 $(PACKAGESDIR)/webkit-1.0/webkit-1.0.gi
webkit2gtk-3.0:
$(GENVAPI) --library $(srcdir)/webkit2gtk-3.0 --metadatadir $(METADATADIR) --pkg gtk+-3.0 --pkg libsoup-2.4 $(GIRDIR)/WebKit2-3.0.gir
webkit2gtk-web-extension-3.0:
$(GENVAPI) --library $(srcdir)/webkit2gtk-web-extension-3.0 --metadatadir $(METADATADIR) --pkg gtk+-3.0 $(GIRDIR)/WebKit2WebExtension-3.0.gir
DOM* parent="WebKit.DOM" name="DOM(.+)"
DOMEventTarget.add_event_listener skip
\ No newline at end of file
gtk+-3.0
libsoup-2.4
This diff is collapsed.
This source diff could not be displayed because it is too large. You can view the blob instead.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment