Commit 6e281037 authored by Ernestas Kulik's avatar Ernestas Kulik 🦑

build: Fix libcue version comparison

It currently performs a string comparison, as opposed to using
version_compare(), which leads to results like
“unknown >= 2.0.0 == True” when the dependency was not found.

Fixes #32
parent f9e7de0f
Pipeline #34348 passed with stage
in 2 minutes and 59 seconds
......@@ -314,7 +314,7 @@ conf.set('GSTREAMER_BACKEND_DISCOVERER', gstreamer_backend_name == 'Discoverer')
conf.set('GSTREAMER_BACKEND_GUPNP_DLNA', gstreamer_backend_name == 'GUPnP-DLNA')
conf.set('HAVE_HAL', battery_detection_library_name == 'hal')
conf.set('HAVE_LIBCUE', libcue.found())
conf.set('HAVE_LIBCUE2', libcue.version() >= '2.0.0')
conf.set('HAVE_LIBCUE2', libcue.version().version_compare('>= 2.0.0'))
conf.set('HAVE_LIBICU_CHARSET_DETECTION', charset_library_name == 'icu')
conf.set('HAVE_LIBEXIF', libexif.found())
conf.set('HAVE_LIBIPTCDATA', libiptcdata.found())
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment