Commit 46e1626f authored by Martyn Russell's avatar Martyn Russell

libtracker-extract: Clean up CFLAGS/LIBS

parent 9d9a3e40
......@@ -241,6 +241,14 @@ LIBTRACKER_DIRECT_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
PKG_CHECK_MODULES(LIBTRACKER_DIRECT, [$LIBTRACKER_DIRECT_REQUIRED])
# Check requirements for libtracker-extract
LIBTRACKER_EXTRACT_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
gio-unix-2.0 >= $GLIB_REQUIRED
dbus-1 >= $DBUS_REQUIRED
dbus-glib-1 >= $DBUS_GLIB_REQUIRED"
PKG_CHECK_MODULES(LIBTRACKER_EXTRACT, [$LIBTRACKER_EXTRACT_REQUIRED])
# Check for enca, detects defect Russian or Cyrillic language specifics in mp3s
AC_ARG_WITH(enca,
AS_HELP_STRING([--with-enca],
......
......@@ -8,9 +8,8 @@ INCLUDES = \
-I$(top_builddir)/src \
-I$(top_builddir)/src/libtracker-sparql \
$(WARN_CFLAGS) \
$(GLIB2_CFLAGS) \
$(GCOV_CFLAGS) \
$(GIO_CFLAGS) \
$(LIBTRACKER_EXTRACT_CFLAGS) \
$(LIBIPTCDATA_CFLAGS) \
$(LIBEXIF_CFLAGS) \
$(EXEMPI_CFLAGS)
......@@ -46,9 +45,8 @@ libtracker_extract_@TRACKER_API_VERSION@_la_LDFLAGS = \
libtracker_extract_@TRACKER_API_VERSION@_la_LIBADD = \
$(top_builddir)/src/libtracker-sparql/libtracker-sparql-@TRACKER_API_VERSION@.la \
$(top_builddir)/src/libtracker-common/libtracker-common.la \
$(GIO_LIBS) \
$(GCOV_LIBS) \
$(GLIB2_LIBS) \
$(LIBTRACKER_EXTRACT_LIBS) \
$(LIBIPTCDATA_LIBS) \
$(LIBEXIF_LIBS) \
$(EXEMPI_LIBS)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment