Commit 5cbc27ef authored by Emanuele Aina's avatar Emanuele Aina Committed by Marco Barisione

tp-account-widgets: Move account widgets code in the tp-account-widgets subdir

Start moving the account widgets code in a subdir before fully isolating
it and stubbing it out in a submodule.

https://bugzilla.gnome.org/show_bug.cgi?id=699492
parent 80a78928
MY_SUBDIRS = tools extensions po data libempathy libempathy-gtk src help tests
TPAW_SUBDIRS = tp-account-widgets
NST_SUBDIRS = nautilus-sendto-plugin
GOA_SUBDIRS = goa-mc-plugin
UOA_SUBDIRS = ubuntu-online-accounts
DIST_SUBDIRS = $(MY_SUBDIRS) $(NST_SUBDIRS) $(GOA_SUBDIRS) $(UOA_SUBDIRS)
DIST_SUBDIRS = $(TPAW_SUBDIRS) $(MY_SUBDIRS) $(NST_SUBDIRS) $(GOA_SUBDIRS) $(UOA_SUBDIRS)
SUBDIRS = $(MY_SUBDIRS)
SUBDIRS = $(TPAW_SUBDIRS) $(MY_SUBDIRS)
if HAVE_NST
SUBDIRS += $(NST_SUBDIRS)
......
......@@ -637,6 +637,7 @@ AC_CONFIG_FILES([
data/themes/Makefile
extensions/Makefile
po/Makefile.in
tp-account-widgets/Makefile
libempathy/Makefile
libempathy-gtk/Makefile
src/Makefile
......
empathy-account-widgets-resources.[ch]
empathy-gtk-marshal.*
*.gladep
......@@ -4,6 +4,7 @@ include $(top_srcdir)/tools/flymake.mk
AM_CPPFLAGS = \
$(ERROR_CFLAGS) \
-I$(top_srcdir)/tp-account-widgets \
-I$(top_srcdir)/libempathy \
-I$(top_srcdir)/extensions \
-DDATADIR=\""$(datadir)"\" \
......@@ -22,18 +23,12 @@ AM_CPPFLAGS = \
$(DISABLE_DEPRECATED)
BUILT_SOURCES = \
empathy-account-widgets-resources.c \
empathy-account-widgets-resources.h \
empathy-gtk-enum-types.h \
empathy-gtk-enum-types.c
libempathy_gtk_handwritten_source = \
empathy-account-chooser.c \
empathy-account-selector-dialog.c \
empathy-account-widget-irc.c \
empathy-account-widget-private.h \
empathy-account-widget-sip.c \
empathy-account-widget.c \
empathy-avatar-chooser.c \
empathy-avatar-image.c \
empathy-bad-password-dialog.c \
......@@ -64,9 +59,6 @@ libempathy_gtk_handwritten_source = \
empathy-individual-view.c \
empathy-individual-widget.c \
empathy-input-text-view.c \
empathy-irc-network-chooser.c \
empathy-irc-network-chooser-dialog.c \
empathy-irc-network-dialog.c \
empathy-local-xmpp-assistant-widget.c \
empathy-log-window.c \
empathy-new-account-dialog.c \
......@@ -102,9 +94,6 @@ libempathy_gtk_handwritten_source = \
libempathy_gtk_headers = \
empathy-account-chooser.h \
empathy-account-selector-dialog.h \
empathy-account-widget-irc.h \
empathy-account-widget-sip.h \
empathy-account-widget.h \
empathy-avatar-chooser.h \
empathy-avatar-image.h \
empathy-bad-password-dialog.h \
......@@ -136,9 +125,6 @@ libempathy_gtk_headers = \
empathy-individual-view.h \
empathy-individual-widget.h \
empathy-input-text-view.h \
empathy-irc-network-chooser.h \
empathy-irc-network-chooser-dialog.h \
empathy-irc-network-dialog.h \
empathy-local-xmpp-assistant-widget.h \
empathy-log-window.h \
empathy-new-account-dialog.h \
......@@ -183,7 +169,7 @@ libempathy_gtk_la_LDFLAGS = \
libempathy_gtk_la_SOURCES = \
$(libempathy_gtk_handwritten_source) \
$(libempathy_gtk_headers) \
totem-subtitle-encoding.c totem-subtitle-encoding.h
$(NULL)
# do not distribute generated files
nodist_libempathy_gtk_la_SOURCES =\
......@@ -202,6 +188,7 @@ libempathy_gtk_la_LIBADD = \
$(GCR_LIBS) \
$(MEEGO_LIBS) \
$(CHEESE_LIBS) \
$(top_builddir)/tp-account-widgets/libtp-account-widgets.la \
$(top_builddir)/libempathy-gtk/egg-list-box/libegglistbox.la \
$(top_builddir)/libempathy/libempathy.la
......@@ -272,17 +259,7 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
&& cp xgen-gtc $(@F) \
&& rm -f xgen-gtc
account_widgets_resource_files = $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(srcdir) $(srcdir)/empathy-account-widgets.gresource.xml)
empathy-account-widgets-resources.c: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
empathy-account-widgets-resources.h: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
EXTRA_DIST = \
empathy-account-widgets.gresource.xml \
$(account_widgets_ui_files) \
$(ui_DATA)
if HAVE_GEOCLUE
......
......@@ -3,6 +3,7 @@ include $(top_srcdir)/tools/flymake.mk
CPPFLAGS_COMMON = \
$(EMPATHY_CFLAGS) \
$(ERROR_CFLAGS) \
-I$(top_srcdir)/tp-account-widgets \
-I$(top_srcdir)/libempathy-gtk \
-I$(top_srcdir)/libempathy \
-I$(top_srcdir)/extensions \
......@@ -22,6 +23,7 @@ AM_CPPFLAGS = \
$(NULL)
LDADD = \
$(top_builddir)/tp-account-widgets/libtp-account-widgets.la \
$(top_builddir)/libempathy-gtk/libempathy-gtk.la \
$(top_builddir)/libempathy/libempathy.la \
$(top_builddir)/extensions/libemp-extensions.la \
......
empathy-account-widgets-resources.[ch]
include $(top_srcdir)/tools/flymake.mk
AM_CPPFLAGS = \
$(ERROR_CFLAGS) \
-I$(top_srcdir)/libempathy \
-I$(top_srcdir)/libempathy-gtk \
-DDATADIR=\""$(datadir)"\" \
-DPKGDATADIR=\""$(pkgdatadir)"\" \
-DG_LOG_DOMAIN=\"empathy\" \
-DGCR_API_SUBJECT_TO_CHANGE \
$(EMPATHY_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
BUILT_SOURCES = \
empathy-account-widgets-resources.c \
empathy-account-widgets-resources.h \
$(NULL)
libtp_account_widgets_sources = \
empathy-account-widget.c \
empathy-account-widget-irc.c \
empathy-account-widget-private.h \
empathy-account-widget-sip.c \
empathy-irc-network-chooser.c \
empathy-irc-network-chooser-dialog.c \
empathy-irc-network-dialog.c \
totem-subtitle-encoding.c \
$(NULL)
libtp_account_widgets_headers = \
empathy-account-widget.h \
empathy-account-widget-irc.h \
empathy-account-widget-sip.h \
empathy-irc-network-chooser-dialog.h \
empathy-irc-network-chooser.h \
empathy-irc-network-dialog.h \
totem-subtitle-encoding.h \
$(NULL)
pkglib_LTLIBRARIES = libtp-account-widgets.la
# libtp-account-widgets's API is not stable and will never be, so use -release to make the
# SONAME of the plugin library change with every Empathy release.
libtp_account_widgets_la_LDFLAGS = \
-no-undefined \
-release $(VERSION) \
$(NULL)
libtp_account_widgets_la_SOURCES = \
$(libtp_account_widgets_sources) \
$(libtp_account_widgets_headers) \
$(NULL)
# do not distribute generated files
nodist_libtp_account_widgets_la_SOURCES = \
$(BUILT_SOURCES)
check_c_sources = \
$(libtp_account_widgets_sources) \
$(libtp_account_widgets_headers) \
$(NULL)
include $(top_srcdir)/tools/check-coding-style.mk
check-local: check-coding-style
account_widgets_ui_files = \
empathy-account-widget-generic.ui \
empathy-account-widget-jabber.ui \
empathy-account-widget-msn.ui \
empathy-account-widget-sip.ui \
empathy-account-widget-local-xmpp.ui \
empathy-account-widget-irc.ui \
empathy-account-widget-icq.ui \
empathy-account-widget-yahoo.ui \
empathy-account-widget-groupwise.ui \
empathy-account-widget-aim.ui \
$(NULL)
account_widgets_resource_files = $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(srcdir) $(srcdir)/empathy-account-widgets.gresource.xml)
empathy-account-widgets-resources.c: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
empathy-account-widgets-resources.h: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
EXTRA_DIST = \
empathy-account-widgets.gresource.xml \
$(account_widgets_ui_files) \
$(NULL)
CLEANFILES = \
$(BUILT_SOURCES) \
$(NULL)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment