Commit 179e04b2 authored by Christoph Reiter's avatar Christoph Reiter 馃悕

build: drop some checks for unsupported Python versions

parent 07cb8d7d
......@@ -98,6 +98,7 @@ else
'-Wsign-compare',
'-Wstrict-aliasing',
'-Wstrict-prototypes',
'-Wswitch-default',
'-Wundef',
'-Wunused-but-set-variable',
'-Wwrite-strings',
......@@ -118,12 +119,6 @@ else
'-fvisibility=hidden',
]
if not ['3.3', '3.4'].contains(python.language_version())
main_c_args += [
'-Wswitch-default',
]
endif
main_c_args = cc.get_supported_arguments(main_c_args)
endif
......
......@@ -1001,16 +1001,12 @@ def add_ext_compiler_flags(ext, compiler, _cache={}):
"-Wsign-compare",
"-Wstrict-aliasing",
"-Wstrict-prototypes",
"-Wswitch-default",
"-Wundef",
"-Wunused-but-set-variable",
"-Wwrite-strings",
]
if sys.version_info[:2] != (3, 4):
args += [
"-Wswitch-default",
]
args += [
"-Wno-incompatible-pointer-types-discards-qualifiers",
"-Wno-missing-field-initializers",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment