Skip to content

Draft: Upgrade to libgirepository-2.0

Arjan Molenaar requested to merge amolenaar/girepository-2.0 into main

GIRepository is now part of GLib. (Un)fortunately, the API has changed a bit as well.

Migration docs are at https://docs.gtk.org/girepository/migrating-gi.html.

  • This MR makes PyGObject require GLib >= 2.80.0.

Fixes #633.

Merge request reports