Commit ba4a0a65 authored by Martin Pitt's avatar Martin Pitt
Browse files

Bump glib and g-i dependencies to latest stable.

glib 2.38 and g-i 1.38 are from stable GNOME 3.10 which we now assume as
minimal version.

Drop @unittest.skipUnless tags from tests which didn't work with g-i 1.36.
parent 2a5ad2af
......@@ -46,7 +46,8 @@ Requirements
============
* C compiler (GCC and MSVC supported)
* Python 2.7 or higher
* Glib/Gio 2.35.9 or higher
* Glib/Gio 2.38.0 or higher
* gobject-introspection 1.38.0 or higher
* libffi (optional)
Copyright Information
......
......@@ -22,11 +22,11 @@ m4_define(pygobject_micro_version, 1)
m4_define(pygobject_version, pygobject_major_version.pygobject_minor_version.pygobject_micro_version)
dnl versions of packages we require ...
m4_define(introspection_required_version, 1.35.9)
m4_define(introspection_required_version, 1.38.0)
m4_define(py2cairo_required_version, 1.2.0)
m4_define(py3cairo_required_version, 1.10.0)
m4_define(glib_required_version, 2.35.9)
m4_define(gio_required_version, 2.35.9)
m4_define(glib_required_version, 2.38.0)
m4_define(gio_required_version, 2.38.0)
AC_INIT([pygobject],[pygobject_version],
[http://bugzilla.gnome.org/enter_bug.cgi?product=pygobject],
......
......@@ -1246,8 +1246,6 @@ class TestGValue(unittest.TestCase):
value = GObject.Value(GObject.TYPE_INT, 42)
GIMarshallingTests.gvalue_in(value)
@unittest.skipUnless(hasattr(GIMarshallingTests, 'gvalue_in_with_modification'),
'Newer version of gi needed.')
def test_gvalue_in_with_modification(self):
value = GObject.Value(GObject.TYPE_INT, 42)
GIMarshallingTests.gvalue_in_with_modification(value)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment