Commit f87ddb2a authored by Maurice van der Pot's avatar Maurice van der Pot Committed by Maurice van der Pot

Enabling evolution data server backend support caused configure to fail

2008-04-20  Maurice van der Pot  <griffon26@kfk4ever.com>

	* configure.in: Enabling evolution data server backend support caused
	configure to fail (bug #528971). Thanks to Robin Cook <rcook@wyrms.net> for
	noticing and providing a patch.
	* libplanner/Makefile.am: Adding -lm to LIBADD for libplanner as suggested
	by Marcin Banasiak <megabajt@pld-linux.org>, hopefully fixing bug #528582
	reported by Patryk Zawadzki <patrys@pld-linux.org>.


svn path=/trunk/; revision=909
parent ce0f566b
2008-04-20 Maurice van der Pot <griffon26@kfk4ever.com>
* configure.in: Enabling evolution data server backend support caused
configure to fail (bug #528971). Thanks to Robin Cook <rcook@wyrms.net> for
noticing and providing a patch.
* libplanner/Makefile.am: Adding -lm to LIBADD for libplanner as suggested
by Marcin Banasiak <megabajt@pld-linux.org>, hopefully fixing bug #528582
reported by Patryk Zawadzki <patrys@pld-linux.org>.
2008-04-16 Maurice van der Pot <griffon26@kfk4ever.com>
* NEWS:
......
......@@ -282,18 +282,17 @@ AC_ARG_ENABLE(eds_backend, [ --enable-eds-backend build evolution-data-se
if test "x$enable_eds_backend" = "xyes" ; then
EDS_REQUIRED=1.1.0
EDS_PACKAGE=1.2
EVOLUTION_PACKAGE=2.2
EVOLUTION_REQUIRED=2.1.3
PKG_CHECK_MODULES(EDS_BACKEND,
[
libecal-$EDS_PACKAGE >= $EDS_REQUIRED
libedata-cal-$EDS_PACKAGE >= $EDS_REQUIRED
libedataserver-$EDS_PACKAGE >= $EDS_REQUIRED
evolution-plugin-$EVOLUTION_PACKAGE >= $EVOLUTION_REQUIRED
evolution-plugin >= $EVOLUTION_REQUIRED
])
extensiondir=`$PKG_CONFIG --variable=extensiondir evolution-data-server-$EDS_PACKAGE`
AC_SUBST(extensiondir)
plugindir=`$PKG_CONFIG --variable=plugindir evolution-plugin-$EVOLUTION_PACKAGE`
plugindir=`$PKG_CONFIG --variable=plugindir evolution-plugin`
AC_SUBST(plugindir)
use_eds_backend=yes
else
......
......@@ -56,7 +56,7 @@ libplannerinclude_HEADERS = \
mrp-error.h \
mrp-paths.h
libplanner_1_la_LIBADD = $(LIBPLANNER_LIBS)
libplanner_1_la_LIBADD = $(LIBPLANNER_LIBS) -lm
libplannerincludedir = $(includedir)/planner-1.0/libplanner
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment