Commit f7307cb6 authored by Lubomir Rintel's avatar Lubomir Rintel

build: disable libnm-gtk by default

By now nobody should be using this. Keep the code around for a little
longer just in case anybody still uses this.

!29
parent 57ef36bf
Pipeline #36575 passed with stages
in 19 minutes and 51 seconds
......@@ -114,7 +114,6 @@
- ./configure
--disable-silent-rules
--with-more-asserts=no
--without-libnm-gtk
--disable-nls
--disable-iso-codes
--disable-mobile-broadband-provider-info
......@@ -142,7 +141,6 @@
- ./configure
--disable-silent-rules
--with-more-asserts=yes
--without-libnm-gtk
--enable-nls
--enable-iso-codes
--enable-mobile-broadband-provider-info
......@@ -206,7 +204,6 @@ pages:
- cd network-manager-applet-*/
- ./configure
--disable-silent-rules
--without-libnm-gtk
--enable-gtk-doc
- make -j
- cd ..
......
......@@ -31,6 +31,7 @@ DISTCHECK_CONFIGURE_FLAGS = \
--enable-gtk-doc \
--enable-introspection \
--enable-more-warnings=error \
--with-libnm-gtk \
--with-wwan \
--with-team \
--with-gcr
......
=======================================================
network-manager-applet-1.8.20 (not released yet)
Overview of changes since network-manager-applet-1.8.18
=======================================================
* Build of libnm-gtk, a libnm-glib compatibility library, is disabled by
default. It can be enabled by passing --with-libnm-gtk to configure
script. Nobody should need it by now. Users that still use this are
encouraged to let us know before the libnm-glib support is removed for good.
=======================================================
network-manager-applet-1.8.18
Overview of changes since network-manager-applet-1.8.16
......
......@@ -125,8 +125,8 @@ dnl API documentation
dnl
GTK_DOC_CHECK(1.0)
AC_ARG_WITH(libnm-gtk, AS_HELP_STRING([--without-libnm-gtk], [dont build legacy library libnm-gtk which depends on libnm-glib/libnm-util/dbus-glib]))
if test "$with_libnm_gtk" != no; then
AC_ARG_WITH(libnm-gtk, AS_HELP_STRING([--with-libnm-gtk], [build legacy library libnm-gtk which depends on libnm-glib/libnm-util/dbus-glib (deprecated)]))
if test "$with_libnm_gtk" == yes; then
PKG_CHECK_MODULES(LIBNM_GLIB,
[gio-2.0 >= 2.38
NetworkManager >= 1.7
......@@ -137,14 +137,15 @@ if test "$with_libnm_gtk" != no; then
:,
[AC_MSG_FAILURE([$LIBNM_GLIB_PKG_ERRORS
Configure with --without-libnm-gtk if you do not need the legacy library])])
with_libnm_gtk=yes
Configure withhout --with-libnm-gtk if you do not need the legacy library])])
LIBNM_GLIB_CFLAGS="$LIBNM_GLIB_CFLAGS -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_38"
LIBNM_GLIB_CFLAGS="$LIBNM_GLIB_CFLAGS -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_38"
LIBNM_GLIB_CFLAGS="$LIBNM_GLIB_CFLAGS -DNM_VERSION_MIN_REQUIRED=NM_VERSION_1_4"
LIBNM_GLIB_CFLAGS="$LIBNM_GLIB_CFLAGS -DNM_VERSION_MAX_ALLOWED=NM_VERSION_1_4"
else
with_libnm_gtk=no
fi
AM_CONDITIONAL(WITH_LIBNM_GTK, test "$with_libnm_gtk" != "no")
AM_CONDITIONAL(WITH_LIBNM_GTK, test "$with_libnm_gtk" == "yes")
PKG_CHECK_MODULES(LIBNM, [libnm >= 1.7 gio-2.0 >= 2.38 gmodule-export-2.0])
LIBNM_CFLAGS="$LIBNM_CFLAGS -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_38"
......
option('libnm_gtk', type: 'boolean', value: true, description: 'build legacy library libnm-gtk which depends on libnm-glib/libnm-util/dbus-glib')
option('libnm_gtk', type: 'boolean', value: false, description: 'build legacy library libnm-gtk which depends on libnm-glib/libnm-util/dbus-glib')
option('appindicator', type: 'string', value: 'no', description: 'Build with lib(ayatana-)appindicator support in addition to xembed systray support (no|yes|auto|ayatana|ubuntu). Default is "no", "yes" is an alias for "auto".')
option('wwan', type: 'boolean', value: true, description: 'Enable WWAN support.')
option('selinux', type: 'boolean', value: true, description: 'Enable support for adjusting SELinux labels in configuration editor.')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment