Commit 1eb17ef9 authored by Lubomir Rintel's avatar Lubomir Rintel

build: fix required GTK3 version

The GtkBuilder files and the autoconf script all depend on 3.10.
However, a few places were left where 3.4 was forgotten.

Also "GTK_VERSION" was used instead of "GDK_VERSION" in some spots --
fix that too.
parent b4c365b1
......@@ -163,7 +163,7 @@ fi
PKG_CHECK_MODULES(NOTIFY, [libnotify >= 0.4.3])
PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.10)
GTK3_CFLAGS="$GTK3_CFLAGS -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_4 -DGTK_VERSION_MAX_ALLOWED=GTK_VERSION_3_4"
GTK3_CFLAGS="$GTK3_CFLAGS -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_10 -DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_3_10"
AC_ARG_WITH([appindicator],
AS_HELP_STRING([--with-appindicator=no|yes|auto|ayatana|ubuntu], [Build with lib(ayatana-)appindicator support in addition to xembed systray support.]),
......
......@@ -147,13 +147,13 @@ libsecret_dep = dependency('libsecret-1', version: '>= 0.18')
m_dep = cc.find_library('m')
# Check for gtk+
gtk_req_version = '>= 3.4'
gtk_req_version = '>= 3.10'
gtk_dep = declare_dependency(
dependencies: dependency('gtk+-3.0', version: gtk_req_version),
compile_args: [
'-DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_4',
'-DGTK_VERSION_MAX_ALLOWED=GTK_VERSION_3_4'
'-DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_10',
'-DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_3_10'
]
)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment