Commit fd50ac50 authored by Ernestas Kulik's avatar Ernestas Kulik 🦑 Committed by Carlos Soriano Sánchez

meson: set correct libnautilus-extension version in .pc

Currently, when building with Meson, the version of the pkg-config file
for libnautilus-extension is set to the version of the library itself.
This is incompatible with how it was before - the version was set to the
version of Nautilus. That breaks some modules that build extensions
(e.g. file-roller).

https://bugzilla.gnome.org/show_bug.cgi?id=779472
parent 76cefc82
......@@ -59,7 +59,7 @@ pkgconfig_data.set ('exec_prefix', '${prefix}')
pkgconfig_data.set ('libdir', join_paths ('${exec_prefix}', libdir))
pkgconfig_data.set ('includedir', join_paths ('${prefix}', includedir))
pkgconfig_data.set ('extensiondir', join_paths ('${exec_prefix}', extensiondir))
pkgconfig_data.set ('VERSION', nautilus_extension_version)
pkgconfig_data.set ('VERSION', meson.project_version ())
configure_file (input: 'libnautilus-extension.pc.in',
output: 'libnautilus-extension.pc',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment