Commit f6e557ac authored by Ernestas Kulik's avatar Ernestas Kulik

configure.ac: only check for tracker-sparql-1.0

In systems where Tracker is not installed, building Nautilus with it
enabled will check for 1.0, 0.18 and 0.16. Since older versions may not
be installable from distribution packages, we should only care about
1.0.

https://bugzilla.gnome.org/show_bug.cgi?id=779037
parent 77cd0823
......@@ -249,15 +249,7 @@ AC_ARG_ENABLE(tracker,
[enable_tracker=yes])
if test "x$enable_tracker" != "xno"; then
if $PKG_CONFIG --exists tracker-sparql-1.0; then
PKG_CHECK_MODULES(TRACKER, tracker-sparql-1.0)
else
if $PKG_CONFIG --exists tracker-sparql-0.18; then
PKG_CHECK_MODULES(TRACKER, tracker-sparql-0.18)
else
PKG_CHECK_MODULES(TRACKER, tracker-sparql-0.16)
fi
fi
PKG_CHECK_MODULES([TRACKER], [tracker-sparql-1.0])
AC_DEFINE(ENABLE_TRACKER, 1, [Define to enable Tracker support])
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment