Commit df5dd7b8 authored by Eric Fischer's avatar Eric Fischer Committed by Eric Fischer

Merge from 1.0 branch:

2001-03-12  Eric Fischer  <eric@eazel.com>

        Merge from 1.0 branch:

        reviewed by: Robin * Slomkowski <rslomkow@eazel.com>

        * configure.in:
        Change ammonite version checking to use the same logic as
        other version number checks, to fix the broken tinderbox

        * nautilus.spec.in:
        Inherit the required ammonite version number from configure.in
parent 30d718c1
2001-03-12 Eric Fischer <eric@eazel.com>
Merge from 1.0 branch:
reviewed by: Robin * Slomkowski <rslomkow@eazel.com>
* configure.in:
Change ammonite version checking to use the same logic as
other version number checks, to fix the broken tinderbox
* nautilus.spec.in:
Inherit the required ammonite version number from configure.in
2001-03-12 John Sullivan <sullivan@eazel.com>
reviewed by: Ramiro Estrugo <ramiro@eazel.com>
......
......@@ -26,6 +26,7 @@ MEDUSA_REQUIRED=0.2.2
ESOUND_REQUIRED=0.2
LIBGHTTP_REQUIRED=1.0.9
SCROLLKEEPER_REQUIRED=0.1.4
AMMONITE_REQUIRED=0.8.7
AC_SUBST(IMLIB_REQUIRED)
AC_SUBST(LIBXML_REQUIRED)
......@@ -847,28 +848,12 @@ dnl = Begin tests for ammonite (--enable-eazel-services only)
dnl ====================================
if test "x$EAZEL_SERVICES_ENABLED" = "xyes" ;
then
AC_MSG_CHECKING(for Ammonite >= 0.8.7)
if test -n `gnome-config --libs ammonite | cut -d ' ' -f1`;
then
vers=`gnome-config --modversion ammonite | sed -e "s/[^-]*-//" | \
awk 'BEGIN { FS = "."; } { printf "%d", $1 * 1000 + $2 * 100 + $3;}'`
if test "$vers" -ge 807; then
ammonite_ok=true;
else
ammonite_ok=false
fi
fi
EAZEL_VERSION_INSIST(ammonite, $GNOME_CONFIG --modversion ammonite | awk -F- '{print $2}', >=, AMMONITE_REQUIRED)
if $ammonite_ok; then
AMMONITE_CFLAGS=`gnome-config --cflags ammonite`
AMMONITE_LIBS=`gnome-config --libs ammonite`
AC_MSG_RESULT(yes)
AC_SUBST(AMMONITE_CFLAGS)
AC_SUBST(AMMONITE_LIBS)
else
AC_MSG_RESULT(no)
AC_MSG_ERROR(Ammonite 0.8.7 or newer is required for Eazel Services. Please obtain it from Eazel's FTP site)
fi
AMMONITE_CFLAGS=`$GNOME_CONFIG --cflags ammonite`
AMMONITE_LIBS=`$GNOME_CONFIG --libs ammonite`
AC_SUBST(AMMONITE_CFLAGS)
AC_SUBST(AMMONITE_LIBS)
fi
dnl =======================
dnl = End tests for ammonite
......
......@@ -64,7 +64,7 @@ Conflicts: mozilla = M17
Summary: Nautilus component framework for services
Group: User Interface/Desktop
Requires: %name = %{PACKAGE_VERSION}
Requires: ammonite >= 0.1
Requires: ammonite >= @AMMONITE_REQUIRED@
Requires: rpm >= @RPM_VERSION@
Requires: usermode >= 1.35
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment