Commit 6b5cf550 authored by Michael Meeks's avatar Michael Meeks

fix build.

parent dff43991
2002-01-03 Michael Meeks <michael@ximian.com>
* components/image-viewer/io-png.c
(image_save): disable png stuff.
2001-12-21 Michael Meeks <michael@ximian.com>
* configure.in: bump requirements on bonobo to get
something that works well.
2002-01-03 John Fleck <jfleck@inkstain.net>
* help/nautilus-quick-reference/C/index.html
......
......@@ -14,6 +14,7 @@ typedef struct {
CORBA_Environment *ev;
} BStreamData;
#ifdef GNOME2_CONVERSION_COMPLETE
static void
png_write_data_fn (png_structp png_ptr, png_bytep data, png_size_t len)
{
......@@ -30,11 +31,16 @@ png_flush_fn (png_structp png_ptr)
{
g_warning ("Flush nothing");
}
#endif
void
image_save (Bonobo_Stream stream, GdkPixbuf *pixbuf,
CORBA_Environment *ev)
{
g_warning ("Save image unimplemented");
#ifdef GNOME2_CONVERSION_COMPLETE
/* Use Eog */
png_structp png_ptr;
png_infop info_ptr;
guint8 *ptr;
......@@ -115,5 +121,6 @@ image_save (Bonobo_Stream stream, GdkPixbuf *pixbuf,
g_free (data);
CORBA_exception_set (ev, CORBA_USER_EXCEPTION,
ex_Bonobo_Stream_IOError, NULL);
#endif
return;
}
......@@ -9,7 +9,8 @@ dnl ==========================================================================
ART_REQUIRED=2.3.6
BONOBO_ACTIVATION_REQUIRED=0.9.3
BONOBO_REQUIRED=1.106
BONOBO_REQUIRED=1.108
BONOBO_UI_REQUIRED=1.108.1
EEL_REQUIRED=1.0.2
ESOUND_REQUIRED=0.2.22
GCONF_REQUIRED=1.1.3
......@@ -69,7 +70,7 @@ PKG_CHECK_MODULES(ALL, \
gtk+-2.0 >= $GTK_REQUIRED \
libart-2.0 >= $ART_REQUIRED \
libbonobo-2.0 >= $BONOBO_REQUIRED \
libbonoboui-2.0 >= $BONOBO_REQUIRED \
libbonoboui-2.0 >= $BONOBO_UI_REQUIRED \
libgnome-2.0 >= $GNOME_REQUIRED \
libgnomecanvas-2.0 >= $GNOME_CANVAS_REQUIRED \
libgnomeui-2.0 >= $GNOME_UI_REQUIRED \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment