Bump minimum Rust version to 1.34

The last merge to update gtk-rs needs TryFrom, which got stabilized in
Rust 1.34.
parent afb61133
Pipeline #95144 failed with stages
in 47 minutes and 20 seconds
......@@ -32,7 +32,7 @@ minimum version is listed here; you may use a newer version instead.
**Compilers:**
* a C compiler and `make` tool; we recommend GNU `make`.
* rust 1.31 or later
* rust 1.34 or later
* cargo
**Mandatory dependencies:**
......
......@@ -113,7 +113,7 @@ AC_CHECK_PROGS(AR, ar)
dnl Minimum version of rustc that we support
dnl If you change this, please update COMPILING.md
MINIMUM_RUST_MAJOR=1
MINIMUM_RUST_MINOR=31
MINIMUM_RUST_MINOR=34
rust_version=`$RUSTC --version`
version=`echo "$rust_version" | sed -e 's/^rustc //g'`
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment