Commit d97c5e90 authored by Darin Adler's avatar Darin Adler

Replace uses of GNOME_PKGCONFIG_CHECK_MODULES with a single call to

	* configure.in: Replace uses of GNOME_PKGCONFIG_CHECK_MODULES
	with a single call to PKG_CHECK_MODULES.
	* Makefile.am: Use a single set of CFLAGS and LIBS for all.
parent beb5e72e
2001-08-06 Darin Adler <darin@bentspoon.com>
* configure.in: Replace uses of GNOME_PKGCONFIG_CHECK_MODULES
with a single call to PKG_CHECK_MODULES.
* Makefile.am: Use a single set of CFLAGS and LIBS for all.
2001-07-25 Ramiro Estrugo <ramiro@fateware.com>
* librsvg.spec.in:
......
......@@ -43,12 +43,8 @@ librsvginc_HEADERS = \
INCLUDES =\
-I$(top_srcdir) \
-I$(top_builddir) \
$(MODULES_CFLAGS) \
$(FREETYPE2_CFLAGS) \
$(GLIB_CFLAGS) \
$(GDK_PIXBUF_CFLAGS) \
$(GTK_CFLAGS) \
$(XML_CFLAGS) \
$(ART_CFLAGS) \
-DG_LOG_DOMAIN=\"librsvg\" \
-DG_DISABLE_DEPRECATED \
-DGDK_DISABLE_DEPRECATED \
......@@ -57,13 +53,8 @@ INCLUDES =\
DEPS = $(top_builddir)/librsvg-2.la
LDADDS = $(top_builddir)/librsvg-2.la \
$(XML_LIBS) \
$(MODULES_LIBS) \
$(FREETYPE2_LIBS) \
$(GDK_PIXBUF_LIBS) \
$(GTK_LIBS) \
$(GLIB_LIBS) \
$(FREETYPE2_LIBS) \
$(ART_LIBS) \
$(POPT_LIBS) \
$(LIBPNG)
......
......@@ -48,29 +48,9 @@ AC_SUBST(GDK_PIXBUF_REQUIRED)
AC_SUBST(FREETYPE_REQUIRED)
AC_SUBST(POPT_REQUIRED)
GNOME_PKGCONFIG_CHECK_MODULES(GLIB, glib-2.0:$GLIB_REQUIRED gmodule-2.0:$GLIB_REQUIRED gthread-2.0:$GLIB_REQUIRED gtk+-2.0:$GLIB_REQUIRED)
GNOME_PKGCONFIG_CHECK_MODULES(GTK, gtk+-2.0:$GTK_REQUIRED)
GNOME_PKGCONFIG_CHECK_MODULES(GDK_PIXBUF, gdk-pixbuf-2.0:$GDK_PIXBUF_REQUIRED)
GNOME_PKGCONFIG_CHECK_MODULES(XML, libxml-2.0:$XML_REQUIRED)
GNOME_PKGCONFIG_CHECK_MODULES(ART, libart-2.0:$ART_REQUIRED)
dnl AC_DEFINE(GNOME_PLATFORM_VERSION, 1095000)
AC_SUBST(GLIB_LIBS)
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GMODULE_LIBS)
AC_SUBST(GMODULE_CFLAGS)
AC_SUBST(GTHREAD_LIBS)
AC_SUBST(GTHREAD_CFLAGS)
AC_SUBST(GTK_LIBS)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GDK_PIXBUF_LIBS)
AC_SUBST(GDK_PIXBUF_CFLAGS)
AC_SUBST(XML_LIBS)
AC_SUBST(XML_CFLAGS)
AC_SUBST(ART_LIBS)
AC_SUBST(ART_CFLAGS)
PKG_CHECK_MODULES(MODULES, glib-2.0 >= $GLIB_REQUIRED gmodule-2.0 >= $GLIB_REQUIRED gthread-2.0 >= $GLIB_REQUIRED gtk+-2.0 >= $GTK_REQUIRED gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED libxml-2.0 >= $XML_REQUIRED libart-2.0 >= $ART_REQUIRED)
AC_SUBST(MODULES_LIBS)
AC_SUBST(MODULES_CFLAGS)
dnl ====================================
dnl = Begin tests for popt
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment