(#359): Require rust 1.27

The libm crate, as used by nalgebra's dependency on alga, doesn't work
on rust 1.26.

I have no idea why libm is actually being compiled by alga; AFAIK libm
is for microcontrollers that need software floating-point.

Fixes #359
parent 26edb54f
......@@ -31,7 +31,7 @@ minimum version is listed here; you may use a newer version instead.
**Compilers:**
* a C compiler and `make` tool; we recommend GNU `make`.
* rust 1.26 or later
* rust 1.27 or later
* cargo
**Mandatory dependencies:**
......
......@@ -85,7 +85,7 @@ AS_IF(test x$RUSTC = xno,
dnl Minimum version of rustc that we support
dnl If you change this, please update COMPILING.md
MINIMUM_RUST_MAJOR=1
MINIMUM_RUST_MINOR=26
MINIMUM_RUST_MINOR=27
rust_version=`rustc --version`
version=`echo "$rust_version" | sed -e 's/^rustc //g'`
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment