Commit 4d98f619 authored by Darin Adler's avatar Darin Adler

More tweaking. I just can't stop myself.

	* README:
	* configure.in:
	* librsvg.spec.in:
	More tweaking. I just can't stop myself.
parent 91eef0b5
2002-01-04 Darin Adler <darin@bentspoon.com>
* README:
* configure.in:
* librsvg.spec.in:
More tweaking. I just can't stop myself.
2002-01-04 Darin Adler <darin@bentspoon.com>
* configure.in: Bump required libart version to the one
......
README for librsvg 1.1.
This is librsvg 1.1 - the GNOME 2.0 platform development version of
librsvg.
If you are looking for the stable version to use with the GNOME
1.4 platform, please obtain librsvg from GNOME CVS as follows:
cvs co -r librsvg-1-0 librsvg
cvs co -r librsvg-1-0 librsvg
If you have questions or comments about librsvg, please send
email to nautilus-list@lists.eazel.com
......@@ -2,19 +2,19 @@ AC_INIT(rsvg.h)
dnl ===========================================================================
ART_REQUIRED=2.3.8
GDK_PIXBUF_REQUIRED=1.3.7
GLIB_REQUIRED=1.3.1
LIBART_REQUIRED=2.3.8
LIBXML_REQUIRED=2.2.8
PANGOFT2_REQUIRED=0.22
POPT_REQUIRED=1.5
XML_REQUIRED=2.2.8
AC_SUBST(ART_REQUIRED)
AC_SUBST(GDK_PIXBUF_REQUIRED)
AC_SUBST(GLIB_REQUIRED)
AC_SUBST(LIBART_REQUIRED)
AC_SUBST(LIBXML_REQUIRED)
AC_SUBST(PANGOFT2_REQUIRED)
AC_SUBST(POPT_REQUIRED)
AC_SUBST(XML_REQUIRED)
dnl ===========================================================================
......@@ -54,7 +54,12 @@ GNOME_PLATFORM_GNOME_2(yes)
dnl ===========================================================================
PKG_CHECK_MODULES(LIBRSVG, glib-2.0 >= $GLIB_REQUIRED gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED libxml-2.0 >= $XML_REQUIRED libart-2.0 >= $ART_REQUIRED pangoft2 >= $PANGOFT2_REQUIRED)
PKG_CHECK_MODULES(LIBRSVG, \
gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED \
glib-2.0 >= $GLIB_REQUIRED \
libart-2.0 >= $LIBART_REQUIRED \
libxml-2.0 >= $LIBXML_REQUIRED \
pangoft2 >= $PANGOFT2_REQUIRED)
AC_SUBST(LIBRSVG_LIBS)
AC_SUBST(LIBRSVG_CFLAGS)
......
......@@ -18,14 +18,15 @@ Source: %{name}-%{ver}.tar.gz
URL: http://nautilus.eazel.com/
BuildRoot: /var/tmp/%{name}-%{ver}-root
Docdir: %{prefix}/doc
Requires: gdk-pixbuf >= @GDK_PIXBUF_REQUIRED@
Requires: glib >= @GLIB_REQUIRED@
Requires: libart >= @LIBART_REQUIRED@
Requires: libxml >= @LIBXML_REQUIRED@
Requires: gdk-pixbuf >= @GDK_PIXBUF_REQUIRED@
Requires: pango >= @PANGOFT2_REQUIRED@
Requires: popt >= @POPT_REQUIRED@
Requires: pango >= @PANGO_REQUIRED@
%description
Eazel Extension Library
A library that uses libart and pango to render svg files.
%package devel
Summary: Libraries and include files for developing with librsvg.
......@@ -36,14 +37,6 @@ Requires: %name = %{PACKAGE_VERSION}
This package provides the necessary development libraries and include
files to allow you to develop with librsvg.
%changelog
* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
- removed obsoletes from sub packages and added mozilla and trilobite
subpackages
* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
- created this thing
%prep
%setup
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment