Commit bb8aac21 authored by Pavlo Solntsev's avatar Pavlo Solntsev

New options for meson wereadded

With this patch, user can control were glade files should be installed.
Otherwise, they shoudlbe installed to the system directory, where path
is taked from pkg-config. With these options, user has control where
files should go and can set variable to direct Glade to look for the
files.
parent 66787045
......@@ -329,8 +329,19 @@ int main() {
endif
if glade_dep.found()
glade_catalog = glade_dep.get_pkgconfig_variable('catalogdir')
glade_pixmap = glade_dep.get_pkgconfig_variable('pixmapdir')
option_glade_catalog = get_option('glade-catalog-dir')
option_glade_pixmap = get_option('glade-pixmap-dir')
if option_glade_catalog != ''
glade_catalog = option_glade_catalog
else
glade_catalog = glade_dep.get_pkgconfig_variable('catalogdir')
endif
if option_glade_pixmap != ''
glade_pixmap = option_glade_pixmap
else
glade_pixmap = glade_dep.get_pkgconfig_variable('pixmapdir')
endif
endif
subdir('libgda-ui')
subdir('libgda-report')
......@@ -387,4 +398,4 @@ subdir('tests')
subdir('testing')
if get_option('with-examples')
subdir('examples')
endif
\ No newline at end of file
endif
......@@ -15,4 +15,6 @@ option('with-examples', type : 'boolean', value : false, description : 'Compile
option('system-sqlcipher', type : 'boolean', value : true, description : 'Use SQLCipher installed on the system [default=false')
option('enable-tools', type : 'boolean', value : false, description : 'Enable build GUI Tools')
option('enable-ci-environment', type : 'boolean', value : false, description : 'Enable Continous Integration Environment test')
option('glade-catalog-dir', type : 'string', value : '', description : 'Use the given directory to install glade catalog files. If glade is not available this option is ignored. If it is not given the valaue from pkg-config will be used')
option('glade-pixmap-dir', type : 'string', value : '', description : 'Use the given directory to install glade pixmap files. If glade is not available this option is ignored. If it is not given the valaue from pkg-config will be used')
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment