Commit 0213b22e authored by Daniel Espinosa Ortiz's avatar Daniel Espinosa Ortiz

Update SO version

Meson uses same rules as for Autotools for SO versioning.

Version 6.0.0 will be API/ABI break; 5.2 branch uses current as 5,
revision to 1 and age to 1, so new version is current 6, revision
and age are set to 0.

For meson, we should calculate version = current - age, so set to 6
parent 152728de
Pipeline #56890 failed with stages
in 27 minutes and 26 seconds
......@@ -58,9 +58,9 @@ m4_define([req_ver_glib],[2.38.0])
# - If binary compatibility has been broken (e.g. removed or changed interfaces), set GDA_CURRENT += 1, GDA_REVISION and GDA_AGE to 0
# - If interfaces is the same as the previous version, set GDA_REVISION += 1
#
GDA_CURRENT=5
GDA_REVISION=1
GDA_AGE=1
GDA_CURRENT=6
GDA_REVISION=0
GDA_AGE=0
AC_SUBST(GDA_CURRENT)
AC_SUBST(GDA_REVISION)
......
......@@ -24,8 +24,8 @@ libgda_report_sources += libgda_report_rml_sources
libgda_report = library(
'gda-report-'+project_api_version,
libgda_report_sources,
soversion : gda_current,
version : gda_revision,
soversion : LT_VERSION+'.'+LT_AGE+'.'+LT_REVISION,
version : LT_VERSION,
dependencies : [libgda_dep,
gdkpixbuf_dep,
inc_libgda_reporth_dep,
......@@ -56,4 +56,4 @@ test_rt_parser = executable('test-rt-parser',
link_with: [libgda, libgda_report],
install: false
)
test('RtParser', test_rt_parser)
test('RtParser', test_rt_parser)
\ No newline at end of file
......@@ -134,6 +134,8 @@ install_headers(libgda_ui_headers,
libgdaui = library('gda-ui-'+project_api_version,
libgda_ui_sources_all,
soversion : LT_VERSION+'.'+LT_AGE+'.'+LT_REVISION,
version : LT_VERSION,
dependencies: [
libgda_ui_deps,
inc_rooth_dep
......
......@@ -17,8 +17,8 @@ libgda_xslt_sources += gda_xslt_headers
libgda_xslt = library(
'gda-xslt-'+project_api_version,
libgda_xslt_sources,
soversion : gda_current,
version : gda_revision,
soversion : LT_VERSION+'.'+LT_AGE+'.'+LT_REVISION,
version : LT_VERSION,
dependencies : [libgda_dep,
libxslt_dep,
inc_libgda_xslth_dep,
......@@ -32,4 +32,4 @@ libgda_xslt = library(
],
link_with: libgda,
install : true
)
)
\ No newline at end of file
......@@ -341,8 +341,8 @@ endforeach
libgda = library(
'gda-'+project_api_version,
libgda_source_all+valacs,
soversion : gda_current,
version : gda_revision,
soversion : LT_VERSION+'.'+LT_AGE+'.'+LT_REVISION,
version : LT_VERSION,
dependencies : [
libgda_dep,
#ldap_deps,
......
......@@ -21,9 +21,18 @@ project_abi_name = '"' + meson.project_name() + '-' + project_abi_version + '"'
project_api_name = '"' + meson.project_name() + '-' + project_api_version + '"'
project_package = meson.project_name() + '-' + project_api_version
gda_current = '5'
gda_revision ='91'
gda_age = '1'
# LT_VERSION for ABI related changes
# From: https://autotools.io/libtool/version.html
# This rules applies to Meson 0.43
# If interfaces have been changed or added, set GDA_CURRENT += 1 and GDA_AGE += 1, set GDA_REVISION to 0.
# If binary compatibility has been broken (e.g. removed or changed interfaces), set GDA_CURRENT += 1, GDA_REVISION and GDA_AGE to 0
# If interfaces is the same as the previous version, set GDA_REVISION += 1
# Set version to the value of subtract age from current
# Reset current and version to 1 and, age and version to 0 if library's name is changed
LT_CURRENT='6'
LT_REVISION='0'
LT_AGE='0'
LT_VERSION='6'
compiler = meson.get_compiler('c')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment