meson: Add proper Requires to pc files

Make a correction to the Requires specified in the autotools build:
  - champlain requires cairo

Fixes #46
parent 62287f73
......@@ -7,11 +7,14 @@ libchamplain_gtk_sources = [
'gtk-champlain-embed.c',
]
libchamplain_gtk_deps = [
glib_dep,
gobject_dep,
libchamplain_gtk_requires = [
gtk_dep,
clutter_gtk_dep,
]
libchamplain_gtk_deps = libchamplain_gtk_requires + [
glib_dep,
gobject_dep,
libchamplain_dep,
]
......@@ -103,7 +106,7 @@ endif
libchamplain_gtk_dep = declare_dependency(
link_with: libchamplain_gtk_sha,
include_directories: rootdir,
dependencies: libchamplain_gtk_deps,
dependencies: libchamplain_gtk_requires + [libchamplain_dep],
sources: libchamplain_gtk_dep_sources,
)
......@@ -112,4 +115,5 @@ libchamplain_gtk_pc = pkg.generate(
description: 'Gtk+ Widget wrapper for libchamplain',
subdirs: package_string,
install_dir: pkgconfigdir,
requires: libchamplain_gtk_requires + [libchamplain_sha],
)
......@@ -85,13 +85,16 @@ if build_with_memphis
]
endif
libchamplain_deps = [
libm_dep,
libchamplain_requires = [
glib_dep,
gobject_dep,
gio_dep,
clutter_dep,
cairo_dep,
clutter_dep,
]
libchamplain_deps = libchamplain_requires + [
libm_dep,
gio_dep,
sqlite_dep,
libsoup_dep,
]
......@@ -246,7 +249,7 @@ endif
libchamplain_dep = declare_dependency(
link_with: libchamplain_sha,
include_directories: rootdir,
dependencies: libchamplain_deps,
dependencies: libchamplain_requires,
sources: libchamplain_dep_sources,
)
......@@ -256,4 +259,5 @@ libchamplain_pc = pkg.generate(
description: 'Map View for Clutter',
subdirs: package_string,
install_dir: pkgconfigdir,
requires: libchamplain_requires,
)
libchamplain_demos = [
['minimal', 'minimal.c'],
['launcher', ['launcher.c', 'markers.c']],
['animated-marker', 'animated-marker.c'],
['polygons', 'polygons.c'],
['url-marker', 'url-marker.c'],
['create_destroy_test', 'create-destroy-test.c'],
['minimal', 'minimal.c', []],
['launcher', ['launcher.c', 'markers.c'], []],
['animated-marker', 'animated-marker.c', []],
['polygons', 'polygons.c', []],
['url-marker', 'url-marker.c', [libsoup_dep]],
['create_destroy_test', 'create-destroy-test.c', []],
]
foreach demo: libchamplain_demos
demo_name = demo.get(0)
demo_sources = demo.get(1)
demo_deps = demo.get(2)
executable(
demo_name,
demo_sources,
install: false,
dependencies: [
libchamplain_dep,
]
dependencies: demo_deps + [libchamplain_dep],
)
endforeach
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment