Commit ec2525b4 authored by Emmanuele Bassi's avatar Emmanuele Bassi

build: Update the macOS linker flags

Use the interface and binary ages to define the current version.

https://bugzilla.gnome.org/show_bug.cgi?id=785053
parent 5b58d89e
......@@ -147,7 +147,10 @@ endif
# Maintain compatibility with autotools
if host_system == 'darwin'
common_ldflags += [ '-compatibility_version 1', '-current_version 1.0', ]
common_ldflags += [
'-compatibility_version 1',
'-current_version @0@.@1@'.format(json_binary_age - json_interface_age, json_interface_age),
]
endif
root_dir = include_directories('.')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment