Commit 6d89b7e7 authored by Rafael Fontenelle's avatar Rafael Fontenelle 🇧🇷

core-deps-3.24: Patch mozjs38 for sed 4.3+ compliance

File js/src/configure was generated with a [:space:], but the
correct syntax is [[:space:]]. Since sed version 4.3, this is
considered as a syntax error.
parent e12721b3
......@@ -1551,6 +1551,7 @@
<patch file="mozjs38-pkg-config-version.patch" strip="1"/>
<patch file="mozjs38-install-name.patch" strip="1"/>
<patch file="mozjs38-copy-headers.patch" strip="1"/>
<patch file="mozjs38-add-bracket.patch" strip="1"/>
<patch file="mozjs38-1269317.patch" strip="1"/>
</branch>
<dependencies>
......
Add bracket for sed 4.3 compliance
Based on upstream fix by Daniel Stenberg in 09 jan 2017
See: https://hg.mozilla.org/mozilla-central/rev/ebcbf47a83e7
--- a/js/src/configure 2017-02-21 16:56:42.350105741 -0300
+++ b/js/src/configure 2017-02-21 17:33:13.183493978 -0300
@@ -15231,7 +15231,7 @@
fi
fi
- version=`sed -n 's/^[:space:]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
+ version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
if test x"$version" = x; then
{ echo "configure: error: cannot determine icu version number from uvernum.h header file $lineno" 1>&2; echo "configure: error: cannot determine icu version number from uvernum.h header file $lineno" 1>&5; exit 1; }
fi
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment