Commit 44bde0f5 authored by Carlos Garcia Campos's avatar Carlos Garcia Campos

core-deps-3.10: WebKitGTK+ 2.1.2

Remove the harfbuzz-icu patch that is no longer needed.
parent 0540f08a
......@@ -1042,10 +1042,9 @@
autogenargs="--enable-introspection --disable-silent-rules --with-gstreamer=1.0">
<pkg-config>webkitgtk-3.0.pc</pkg-config>
<branch repo="webkitgtk.org"
module="webkitgtk-2.1.1.tar.xz" version="2.1.1"
hash="sha256:8c67512bb169a06aff145158bc76ea7cc0cdd5c9a45894ae820a94cb0fb4bbd2"
size="9121880">
<patch file="webkitgtk-fix-harfbuzz-icu.patch" strip="1"/>
module="webkitgtk-2.1.2.tar.xz" version="2.1.2"
hash="sha256:8c5e386747e0f776e97f6294c3ae8e91e988001c6b7e0cb430970e9088ff2c4f"
size="9176424">
</branch>
<dependencies>
<dep package="at-spi2-core"/>
......
https://bugs.webkit.org/show_bug.cgi?id=116978
diff --git a/Source/autotools/FindDependencies.m4 b/Source/autotools/FindDependencies.m4
index a9067c5..aead295 100644
--- a/Source/autotools/FindDependencies.m4
+++ b/Source/autotools/FindDependencies.m4
@@ -373,6 +373,13 @@
PKG_CHECK_MODULES([FREETYPE],
[cairo-ft fontconfig >= fontconfig_required_version freetype2 >= freetype2_required_version harfbuzz >= harfbuzz_required_version])
fi
+# HarfBuzz 0.9.18 splits harbuzz-icu into a separate library.
+# Since we support earlier HarfBuzz versions we keep this conditional for now.
+if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
+ PKG_CHECK_MODULES(HARFBUZZ_ICU, harfbuzz-icu >= $harfbuzz_required_version)
+ FREETYPE_CFLAGS+=" $HARFBUZZ_ICU_CFLAGS"
+ FREETYPE_LIBS+=" $HARFBUZZ_ICU_LIBS"
+fi
AC_SUBST([FREETYPE_CFLAGS])
AC_SUBST([FREETYPE_LIBS])
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment