Commit 062c028c authored by Martin Pitt's avatar Martin Pitt

*-3.*: Switch pygobject deps to pygobject-python2

The previous commit switched pygobject to Python 3 by default. As our current
modules expect Python 2, switch all dependencies to pygobject-python2 for now.
As modules get ported to Python 3, they should switch their dependency back to
pygobject.

https://bugzilla.gnome.org/show_bug.cgi?id=687743
parent fdd83e67
......@@ -476,7 +476,7 @@
<autotools id="pyatspi2">
<branch/>
<dependencies>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
</dependencies>
<suggests>
<dep package="at-spi2-core"/>
......@@ -612,7 +612,7 @@
<dependencies>
<dep package="at-spi2-atk"/> <!-- to make accerciser's gui accessible -->
<dep package="intltool"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="pyatspi2"/>
<dep package="yelp-tools"/>
<dep package="gtk+"/>
......@@ -740,7 +740,7 @@
<branch/>
<dependencies>
<dep package="gtk+"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="gsettings-desktop-schemas"/>
</dependencies>
</autotools>
......@@ -765,7 +765,7 @@
<dep package="gtk+"/>
<dep package="libgsf"/>
<dep package="libxml2"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="pango"/>
</dependencies>
</autotools>
......@@ -1034,7 +1034,7 @@
<distutils id="gnome-clocks">
<branch/>
<dependencies>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="gtk+"/>
<dep package="libcanberra"/>
<dep package="clutter-gtk"/>
......@@ -1178,7 +1178,7 @@
<dependencies>
<dep package="intltool"/>
<dep package="gtk+"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="yelp-tools"/>
</dependencies>
</autotools>
......@@ -1348,7 +1348,7 @@
<dep package="intltool"/>
<dep package="pyatspi2"/>
<dep package="py2cairo"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="yelp-tools"/>
</dependencies>
</autotools>
......@@ -1369,7 +1369,7 @@
<dep package="libpeas"/>
<dep package="libsoup"/>
<dep package="libxml2"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="totem-pl-parser"/>
</dependencies>
<suggests>
......
......@@ -581,7 +581,7 @@
<suggests>
<dep package="lcms2"/>
<dep package="librsvg"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
</suggests>
</autotools>
......
......@@ -275,7 +275,7 @@
<autotools id="caribou" autogenargs="--disable-gtk2-module">
<branch/>
<dependencies>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="gtk+"/>
<dep package="clutter"/>
<dep package="libgee"/>
......@@ -747,7 +747,7 @@
<suggests>
<dep package="gjs"/>
<dep package="glade"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="seed"/>
</suggests>
</autotools>
......
......@@ -100,7 +100,7 @@
<dep package="dbus-glib"/>
</dependencies>
<suggests>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
</suggests>
</autotools>
......
......@@ -601,7 +601,7 @@
<dependencies>
<dep package="py2cairo"/>
<dep package="pyatspi2"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="pygtk"/>
</dependencies>
</distutils>
......@@ -944,7 +944,7 @@
<dep package="goocanvasmm"/>
<dep package="libepc"/>
<dep package="evince"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
</dependencies>
</autotools>
......@@ -1022,7 +1022,7 @@
<dep package="gst-editing-services"/>
<dep package="gst-plugins-base"/>
<dep package="gst-plugins-good"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="py2cairo"/>
</dependencies>
</autotools>
......@@ -1363,7 +1363,7 @@
<dep package="gsettings-desktop-schemas"/>
<dep package="libchamplain"/>
<dep package="libgdata"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
</suggests>
</autotools>
......@@ -1642,7 +1642,7 @@
<dep package="libgee-0.6"/>
<dep package="libnotify"/>
<dep package="libsoup"/>
<dep package="pygobject"/>
<dep package="pygobject-python2"/>
<dep package="vala"/>
</dependencies>
</autotools>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment