gnome-suites-core-3.4.modules 32.5 KB
Newer Older
1 2 3 4 5
<?xml version="1.0"?><!--*- mode: nxml; indent-tabs-mode: nil -*-->
<!DOCTYPE moduleset SYSTEM "moduleset.dtd">
<?xml-stylesheet type="text/xsl" href="moduleset.xsl"?>
<!-- vim:set ts=2 expandtab: -->
<moduleset>
6 7

<!-- git repos -->
8 9 10 11 12 13
  <repository type="git" name="git.gnome.org" default="yes"
      href="git://git.gnome.org/"/>
  <repository type="git" name="git.freedesktop.org"
      href="git://anongit.freedesktop.org/git/"/>
  <repository type="git" name="packagekit.gitorious.org"
      href="git://gitorious.org/packagekit"/>
14

15
<!-- tarball repos -->
16 17
  <repository type="tarball" name="avahi.org"
      href="http://www.avahi.org/download/"/>
18 19 20 21 22 23
  <repository type="tarball" name="dbus"
      href="http://dbus.freedesktop.org/releases/"/>
  <repository type="tarball" name="freedesktop.org"
      href="http://freedesktop.org/"/>
  <repository type="tarball" name="kernel.org"
      href="http://www.kernel.org"/>
24 25
  <repository type="tarball" name="telepathy"
      href="http://telepathy.freedesktop.org/releases/"/>
26 27
  <repository type="tarball" name="gnome.org"
      href="http://download.gnome.org/sources/"/>
28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55

<include href="gnome-suites-core-deps-3.4.modules"/>

<!-- Please try to keep organized alphabetically by section -->


<!-- Core User Shell -->

  <autotools id="at-spi2-core">
    <branch/>
    <dependencies>
      <dep package="dbus"/>
      <dep package="glib"/>
    </dependencies>
  </autotools>

  <autotools id="at-spi2-atk">
    <branch/>
    <dependencies>
      <dep package="dbus"/>
      <dep package="glib"/>
      <dep package="atk"/>
      <dep package="libxml2"/>
      <dep package="at-spi2-core"/>
    </dependencies>
  </autotools>

  <autotools id="dconf">
56 57
    <branch repo="gnome.org" module="dconf/0.11/dconf-0.11.5.tar.xz"
            version="0.11.5"
58
            hash="sha256:4f6ffd386b90e85791164794a66860aa16b7ff988f96105ea5ddc15808c776f5"
59
            size="200620"/>
60 61 62 63 64 65 66 67 68 69 70 71
    <dependencies>
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="dbus"/>
      <dep package="vala"/>
      <dep package="libxml2"/>
    </dependencies>
  </autotools>

  <autotools id="evolution-data-server" supports-non-srcdir-builds="no" autogenargs="--enable-vala-bindings">
    <branch/>
    <dependencies>
72
      <dep package="intltool"/>
73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121
      <dep package="libsoup"/>
      <dep package="libxml2"/>
      <dep package="gtk+"/>
      <dep package="gconf"/>
      <dep package="sqlite3"/>
      <dep package="libgweather"/>
      <dep package="libical"/>
      <dep package="libgdata"/>
      <dep package="gnome-online-accounts"/>
      <dep package="liboauth"/>
      <dep package="vala"/>
    </dependencies>
    <suggests>
      <dep package="nspr"/>
      <dep package="nss"/>
    </suggests>
    <after>
      <dep package="libgnome-keyring"/>
    </after>
  </autotools>

  <autotools id="gnome-bluetooth">
    <branch/>
    <dependencies>
      <dep package="gtk+"/>
      <dep package="gtk-doc"/>
      <dep package="glib"/>
      <dep package="dbus-glib"/>
      <dep package="libnotify"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-online-accounts">
    <branch/>
    <dependencies>
      <dep package="gtk+"/>
      <dep package="WebKit"/>
      <dep package="gnome-keyring"/>
      <dep package="libnotify"/>
      <dep package="librest"/>
      <dep package="json-glib"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-control-center" supports-non-srcdir-builds="no">
    <branch/>
    <dependencies>
      <dep package="colord"/>
      <dep package="dbus-glib"/>
122 123
      <dep package="fontconfig"/>
      <dep package="gdk-pixbuf"/>
124 125
      <dep package="glib"/>
      <dep package="gtk+"/>
126
      <dep package="gnome-bluetooth"/>
127 128 129 130 131
      <dep package="gnome-desktop"/>
      <dep package="gnome-doc-utils"/>
      <dep package="gnome-menus"/>
      <dep package="gnome-online-accounts"/>
      <dep package="gnome-settings-daemon"/>
132
      <dep package="gsettings-desktop-schemas"/>
133
      <dep package="intltool"/>
134 135 136 137
      <dep package="iso-codes"/>
      <dep package="libcanberra"/>
      <dep package="libgtop"/>
      <dep package="libgnomekbd"/>
138
      <dep package="libnotify"/>
139
      <dep package="libwacom"/>
140
      <dep package="libxklavier"/>
141 142 143 144 145 146 147 148 149
      <dep package="libxml2"/>
      <dep package="polkit"/>
      <dep package="pulseaudio"/>
      <dep package="sound-theme-freedesktop"/>
      <dep package="upower"/>
    </dependencies>
    <suggests>
      <!-- <dep package="cups"/> -->
      <dep package="accountsservice"/>
150
      <dep package="gstreamer"/>
151 152 153 154 155 156 157
      <dep package="NetworkManager"/>
    </suggests>
  </autotools>

  <autotools id="gnome-desktop" autogenargs="--with-gnome-distributor=JHBuild">
    <branch/>
    <dependencies>
158
      <dep package="intltool"/>
159 160 161 162 163 164 165 166 167 168 169 170 171
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gnome-doc-utils"/>
      <dep package="gsettings-desktop-schemas"/>
      <dep package="gvfs"/> <!-- gvfs-copy used in autogen.sh -->
    </dependencies>
  </autotools>

  <autotools id="gnome-icon-theme">
    <branch/>
    <dependencies>
      <dep package="hicolor-icon-theme"/>
      <dep package="icon-naming-utils"/>
172
      <dep package="gnome-common"/>
173
      <dep package="intltool"/>
174 175 176 177 178 179 180 181 182 183 184 185 186 187
      <dep package="gtk+"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-icon-theme-extras">
    <branch/>
    <dependencies>
      <dep package="gnome-icon-theme"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-icon-theme-symbolic">
    <branch/>
    <dependencies>
188
      <dep package="gnome-common"/>
189 190 191 192 193 194 195 196
      <dep package="gtk+"/>
      <dep package="icon-naming-utils"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-keyring">
    <branch/>
    <dependencies>
197
      <dep package="intltool"/>
198
      <dep package="dbus"/>
199
      <dep package="gcr"/>
200 201 202 203 204 205 206 207 208 209 210
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="libgcrypt"/>
      <dep package="libtasn1"/>
      <dep package="p11-kit"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-menus">
    <branch/>
    <dependencies>
211
      <dep package="intltool"/>
212
      <dep package="gnome-common"/>
213 214 215 216 217
      <dep package="glib"/>
      <dep package="gobject-introspection"/>
    </dependencies>
  </autotools>

218
  <autotools id="gnome-packagekit" autogenargs="--enable-strict=no">
219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236
    <branch/>
    <dependencies>
      <dep package="PackageKit"/>
      <dep package="gtk+"/>
      <dep package="libnotify"/>
      <dep package="gnome-menus"/>
      <dep package="libcanberra"/>
      <dep package="gnome-control-center"/>
      <dep package="upower"/>
    </dependencies>
    <suggests>
      <dep package="gudev"/>
    </suggests>
  </autotools>

  <autotools id="gnome-power-manager">
    <branch/>
    <dependencies>
237
      <dep package="intltool"/>
238 239 240 241 242 243 244 245 246 247 248 249 250 251 252
      <dep package="glib"/>
      <dep package="dbus-glib"/>
      <dep package="gtk+"/>
      <dep package="libgnome-keyring"/>
      <dep package="gnome-doc-utils"/>
      <dep package="upower"/>
      <dep package="libnotify"/>
      <dep package="libcanberra"/>
      <dep package="gnome-control-center"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-screensaver">
    <branch/>
    <dependencies>
253
      <dep package="intltool"/>
254 255 256 257 258 259 260 261 262 263 264 265 266 267
      <dep package="gtk+"/>
      <dep package="dbus-glib"/>
      <dep package="gnome-menus"/>
      <dep package="gnome-desktop"/>
      <dep package="libgnomekbd"/>
    </dependencies>
    <suggests>
      <dep package="libnotify"/>
    </suggests>
  </autotools>

  <autotools id="gnome-session">
    <branch/>
    <dependencies>
268
      <dep package="intltool"/>
269 270
      <dep package="gtk+"/>
      <dep package="gconf"/>
271
      <dep package="json-glib"/>
272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291
      <dep package="dbus-glib"/>
      <dep package="startup-notification"/>
      <dep package="upower"/>
      <dep package="librsvg"/>
    </dependencies>
    <suggests>
      <dep package="polkit"/>
    </suggests>
  </autotools>

  <autotools id="gnome-settings-daemon">
    <branch/>
    <dependencies>
      <dep package="colord"/>
      <dep package="glib"/>
      <dep package="gnome-desktop"/>
      <dep package="gnome-doc-utils"/>
      <dep package="gsettings-desktop-schemas"/>
      <dep package="gtk+"/>
      <dep package="gudev"/>
292
      <dep package="intltool"/>
293 294 295
      <dep package="libgnomekbd"/>
      <dep package="libcanberra"/>
      <dep package="libnotify"/>
296
      <dep package="libwacom"/>
297 298 299 300 301 302 303 304 305 306
      <dep package="polkit"/>
      <dep package="pulseaudio"/>
      <dep package="upower"/>
    </dependencies>
    <suggests>
      <!-- <dep package="cups"/> -->
      <dep package="gstreamer"/>
    </suggests>
  </autotools>

307
  <autotools id="gnome-shell" autogenargs="--enable-compile-warnings=maximum">
308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323
    <branch/>
    <dependencies>
      <dep package="caribou"/>
      <dep package="dconf"/>
      <dep package="evolution-data-server"/>
      <dep package="folks"/>
      <dep package="gjs"/>
      <dep package="glib"/>
      <dep package="gnome-bluetooth"/>
      <dep package="gnome-desktop"/>
      <dep package="gnome-icon-theme"/>
      <dep package="gnome-icon-theme-symbolic"/>
      <dep package="gnome-menus"/>
      <dep package="gnome-settings-daemon"/>
      <dep package="gobject-introspection"/>
      <dep package="gtk+"/>
324
      <dep package="intltool"/>
325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347
      <dep package="libcanberra"/>
      <dep package="libcroco"/>
      <dep package="libsoup"/>
      <dep package="mutter"/>
      <dep package="polkit"/>
      <dep package="pulseaudio"/>
      <dep package="startup-notification"/>
      <dep package="telepathy-glib"/>
      <dep package="telepathy-logger"/>
      <dep package="upower"/>
    </dependencies>
    <suggests>
      <dep package="gstreamer"/>
      <dep package="gst-plugins-base"/>
    </suggests>
    <after>
      <dep package="librsvg"/>
    </after>
  </autotools>

  <autotools id="gnome-themes-standard">
    <branch/>
    <dependencies>
348
      <dep package="intltool"/>
349 350 351 352 353 354
      <dep package="cantarell-fonts"/>
      <dep package="gtk-engines"/>
      <dep package="librsvg"/>
    </dependencies>
  </autotools>

355
  <autotools id="gsettings-desktop-schemas" autogenargs="--enable-introspection=yes">
356 357 358
    <branch/>
    <dependencies>
      <dep package="glib"/>
359
      <dep package="gobject-introspection"/>
360 361 362 363 364 365
    </dependencies>
  </autotools>

 <autotools id="gvfs">
    <branch/>
    <dependencies>
366
      <dep package="intltool"/>
367 368 369 370 371 372 373 374 375 376 377 378 379 380 381
      <dep package="glib"/>
      <dep package="dbus"/>
      <dep package="libsoup"/>
    </dependencies>
    <suggests>
      <dep package="gnome-disk-utility"/>
      <dep package="gudev"/>
    </suggests>
  </autotools>

  <autotools id="mousetweaks">
    <branch/>
    <dependencies>
      <dep package="gtk+"/>
      <dep package="gsettings-desktop-schemas"/>
382
      <dep package="intltool"/>
383 384 385
    </dependencies>
  </autotools>

386
  <autotools id="mutter" autogenargs="--enable-compile-warnings=maximum">
387 388
    <branch />
    <dependencies>
389
      <dep package="intltool"/>
390 391
      <dep package="gdk-pixbuf"/>
      <dep package="gtk+"/>
392
      <dep package="gsettings-desktop-schemas"/>
393 394 395 396 397 398 399
      <dep package="zenity"/>
      <dep package="clutter"/>
      <dep package="gobject-introspection"/>
      <dep package="libcanberra"/>
    </dependencies>
  </autotools>

400
  <autotools id="network-manager-applet" autogenargs="--enable-more-warnings=no">
401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418
    <branch/>
    <dependencies>
      <dep package="glib"/>
      <dep package="dbus-glib"/>
      <dep package="gtk+"/>
      <dep package="gconf"/>
      <dep package="gnome-keyring"/>
      <dep package="NetworkManager"/>
      <dep package="libnotify"/>
      <dep package="polkit"/>
    </dependencies>
    <suggests>
      <dep package="mobile-broadband-provider-info"/>
    </suggests>
  </autotools>

  <autotools id="pulseaudio" autogenargs="--disable-udev --disable-hal --disable-oss">
    <pkg-config>libpulse.pc</pkg-config>
419 420 421 422
    <branch repo="freedesktop.org" module="software/pulseaudio/releases/pulseaudio-1.0.tar.xz"
            version="1.0"
            hash="sha256:e63464f8a0975446e2b4cfe768b615a66735c8d092b2366d2bdc7a2a04a249be"
            size="1305008"/>
423
    <dependencies>
424
      <dep package="json"/>
425 426 427 428 429 430 431 432 433 434 435 436 437 438 439
      <dep package="libsndfile"/>
      <dep package="liboil"/>
      <dep package="glib"/>
      <dep package="speex"/>
    </dependencies>
    <after>
      <dep package="libsamplerate"/>
      <dep package="gconf"/>
      <dep package="avahi"/>
      <dep package="bluez"/>
      <dep package="dbus"/>
      <dep package="polkit"/>
    </after>
  </autotools>

440 441 442
  <autotools id="telepathy-mission-control">
    <branch repo="telepathy" module="telepathy-mission-control/telepathy-mission-control-5.9.3.tar.gz"
            version="5.9.3"
443 444
            hash="sha256:774af104627513e7881fa6695912c962ddedcc7628ec859e020fa30000e32cab"
            md5sum="15fc8e560bc67a86393a3138d7ac38e3" size="991250"/>
445 446 447 448 449 450
    <dependencies>
      <dep package="dbus"/>
      <dep package="dbus-glib"/>
      <dep package="telepathy-glib"/>
      <dep package="gnome-keyring"/>
    </dependencies>
451
  </autotools>
452 453 454 455 456 457 458


<!-- Fallback Shell -->

  <autotools id="gconf" autogenargs="--enable-gtk --with-gtk=3.0 --disable-orbit">
    <branch/>
    <dependencies>
459
      <dep package="intltool"/>
460 461 462 463 464 465 466 467 468 469 470 471
      <dep package="libxml2"/>
      <dep package="gtk+"/>
      <dep package="dbus-glib"/>
    </dependencies>
    <suggests>
      <dep package="polkit"/>
    </suggests>
  </autotools>

  <autotools id="gnome-panel">
    <branch/>
    <dependencies>
472
      <dep package="intltool"/>
473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490
      <dep package="gnome-desktop"/>
      <dep package="libwnck"/>
      <dep package="evolution-data-server"/>
      <dep package="gnome-menus"/>
      <dep package="gnome-doc-utils"/>
      <dep package="dbus-glib"/>
      <dep package="librsvg"/>
      <dep package="libgweather"/>
      <dep package="libcanberra"/>
    </dependencies>
    <suggests>
      <dep package="polkit"/>
    </suggests>
  </autotools>

  <autotools id="metacity">
    <branch/>
    <dependencies>
491
      <dep package="intltool"/>
492 493
      <dep package="gdk-pixbuf"/>
      <dep package="gtk+-2"/>
494
      <dep package="gsettings-desktop-schemas"/>
495
      <dep package="intltool"/>
496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513
      <dep package="libcanberra"/>
      <dep package="zenity"/>
    </dependencies>
  </autotools>

  <autotools id="notification-daemon">
    <branch/>
    <dependencies>
      <dep package="dbus"/>
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="libcanberra"/>
    </dependencies>
  </autotools>


<!-- Core Utilities -->

514 515 516
  <autotools id="baobab">
    <branch/>
    <dependencies>
517
      <dep package="intltool"/>
518 519 520 521 522 523 524
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gnome-doc-utils"/>
      <dep package="libgtop"/>
    </dependencies>
  </autotools>

525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541
  <autotools id="brasero">
    <branch/>
    <dependencies>
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gst-plugins-base"/>
      <dep package="libcanberra"/>
      <dep package="libnotify"/>
      <dep package="libxml2"/>
    </dependencies>
    <suggests>
      <dep package="nautilus"/>
      <dep package="totem-pl-parser"/>
      <dep package="tracker"/>
    </suggests>
  </autotools>

542
  <autotools id="empathy" autogenargs="--disable-Werror">
543 544
    <branch/>
    <dependencies>
545 546 547
      <dep package="clutter"/>
      <dep package="clutter-gst"/>
      <dep package="clutter-gtk"/>
548 549
      <dep package="dbus-glib"/>
      <dep package="evolution-data-server"/>
550
      <dep package="intltool"/>
551
      <dep package="farstream"/>
552 553
      <dep package="folks"/>
      <dep package="gcr"/>
554
      <dep package="glib"/>
555
      <dep package="gnome-keyring"/>
556
      <dep package="gnome-online-accounts"/>
557
      <dep package="gnutls"/>
558
      <dep package="gsettings-desktop-schemas"/>
559 560 561 562 563 564
      <dep package="gstreamer"/>
      <dep package="gtk+"/>
      <dep package="libcanberra"/>
      <dep package="libsoup"/>
      <dep package="libxml2"/>
      <dep package="pulseaudio"/>
565
      <dep package="telepathy-farstream"/>
566 567 568 569
      <dep package="telepathy-glib"/>
      <dep package="telepathy-logger"/>
      <dep package="telepathy-mission-control"/>
      <dep package="libnotify"/>
570
      <dep package="WebKit"/>
571 572 573
    </dependencies>
    <suggests>
      <dep package="enchant"/>
574
      <dep package="gudev"/>
575 576
      <dep package="iso-codes"/>
      <dep package="libchamplain"/>
577
      <dep package="NetworkManager"/>
578 579 580 581 582 583
    </suggests>
  </autotools>

  <autotools id="eog">
    <branch/>
    <dependencies>
584
      <dep package="intltool"/>
585 586 587 588 589 590 591 592 593 594 595 596 597 598
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gnome-desktop"/>
      <dep package="gnome-icon-theme"/>
      <dep package="libpeas"/>
    </dependencies>
    <suggests>
      <dep package="pygobject"/>
    </suggests>
  </autotools>

  <autotools id="epiphany">
    <branch/>
    <dependencies>
599
      <dep package="intltool"/>
600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617
      <dep package="iso-codes"/>
      <dep package="gtk+"/>
      <dep package="gnome-doc-utils"/>
      <dep package="startup-notification"/>
      <dep package="WebKit"/>
    </dependencies>
    <suggests>
      <dep package="avahi"/>
      <dep package="enchant"/>
      <dep package="libnotify"/>
      <dep package="libcanberra"/>
      <dep package="nss"/>
    </suggests>
  </autotools>

  <autotools id="evince" autogenargs="--enable-introspection">
    <branch/>
    <dependencies>
618
      <dep package="intltool"/>
619 620 621 622 623 624 625
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="libxml2"/>
      <dep package="gnome-icon-theme"/>
      <dep package="poppler"/>
      <dep package="gnome-doc-utils"/>
      <dep package="nautilus"/>
626
      <dep package="libgxps"/>
627 628 629 630 631 632
    </dependencies>
    <suggests>
      <dep package="libgnome-keyring"/>
    </suggests>
  </autotools>

633
  <autotools id="gcalctool" supports-non-srcdir-builds="no">
634 635
    <branch/>
    <dependencies>
636
      <dep package="intltool"/>
637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652
      <dep package="gtk+"/>
      <dep package="gnome-doc-utils"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-contacts">
    <branch/>
    <dependencies>
      <dep package="folks"/>
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="libnotify"/>
      <dep package="vala"/>
    </dependencies>
  </autotools>

653 654 655
  <autotools id="gnome-dictionary">
    <branch/>
    <dependencies>
656
      <dep package="intltool"/>
657 658 659 660 661 662
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gnome-doc-utils"/>
    </dependencies>
  </autotools>

663
  <autotools id="gnome-disk-utility">
664
    <branch revision="gnome-3-2"/>
665
    <dependencies>
666
      <dep package="glib"/>
667 668 669 670
      <dep package="gtk+"/>
    </dependencies>
  </autotools>

671 672 673
  <autotools id="gnome-font-viewer">
    <branch/>
    <dependencies>
674
      <dep package="intltool"/>
675 676 677 678 679 680 681 682 683
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gnome-doc-utils"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-screenshot">
    <branch/>
    <dependencies>
684
      <dep package="intltool"/>
685 686 687 688 689 690 691 692 693
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gnome-doc-utils"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-search-tool">
    <branch/>
    <dependencies>
694
      <dep package="intltool"/>
695 696 697 698 699 700 701 702 703
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gnome-doc-utils"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-system-log">
    <branch/>
    <dependencies>
704
      <dep package="intltool"/>
705 706 707 708 709 710
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gnome-doc-utils"/>
    </dependencies>
  </autotools>

711 712 713
  <autotools id="gnome-system-monitor">
    <branch/>
    <dependencies>
714
      <dep package="intltool"/>
715 716 717 718 719 720 721 722 723 724 725 726
      <dep package="glib"/>
      <dep package="libwnck"/>
      <dep package="libgtop"/>
      <dep package="gtk+"/>
      <dep package="gnome-icon-theme"/>
      <dep package="gtkmm"/>
      <dep package="libxml2"/>
      <dep package="librsvg"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-terminal" autogenargs="--with-gtk=3.0">
727
    <branch revision="gnome-3-4"/>
728
    <dependencies>
729
      <dep package="intltool"/>
730 731 732 733 734 735 736 737 738 739 740 741 742 743 744 745 746
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gconf"/>
      <dep package="vte"/>
      <dep package="startup-notification"/>
      <dep package="gnome-doc-utils"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-user-docs">
    <branch/>
    <dependencies>
      <dep package="gnome-doc-utils"/>
      <dep package="yelp-tools"/>
    </dependencies>
  </autotools>

747
  <autotools id="gucharmap">
748 749
    <branch/>
    <dependencies>
750
      <dep package="intltool"/>
751 752 753 754 755 756 757 758 759 760 761 762
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="gnome-doc-utils"/>
    </dependencies>
    <suggests>
      <dep package="gconf"/>
    </suggests>
  </autotools>

  <autotools id="nautilus">
    <branch/>
    <dependencies>
763
      <dep package="intltool"/>
764 765 766 767 768 769 770 771 772 773 774 775 776 777 778
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="pango"/>
      <dep package="libxml2"/>
      <dep package="gnome-desktop"/>
      <dep package="gsettings-desktop-schemas"/>
    </dependencies>
    <after>
      <dep package="tracker"/>
    </after>
  </autotools>

  <autotools id="sushi">
    <branch/>
    <dependencies>
779
      <dep package="intltool"/>
780 781
      <dep package="gobject-introspection"/>
      <dep package="gjs"/>
782
      <dep package="libmusicbrainz3"/>
783 784 785 786 787 788 789 790 791 792 793 794 795 796 797
      <dep package="evince"/>
      <dep package="clutter"/>
      <dep package="clutter-gtk"/>
      <dep package="clutter-gst"/>
      <dep package="gtksourceview"/>
      <dep package="WebKit"/>
      <dep package="gstreamer"/>
      <dep package="gst-plugins-base"/>
      <dep package="gtk+"/>
    </dependencies>
  </autotools>

  <autotools id="totem">
    <branch />
    <dependencies>
798
      <dep package="intltool"/>
799 800 801 802 803 804 805 806 807 808 809 810 811 812 813 814 815 816 817 818 819
      <dep package="gtk+"/>
      <dep package="gstreamer"/>
      <dep package="gst-plugins-base"/>
      <dep package="gst-plugins-good"/>
      <dep package="iso-codes"/>
      <dep package="totem-pl-parser"/>
      <dep package="libpeas"/>
      <dep package="clutter-gst"/>
      <dep package="clutter-gtk"/>
      <dep package="mx"/>
    </dependencies>
    <suggests>
      <dep package="libepc"/>
      <dep package="brasero"/>
      <dep package="libgdata"/>
    </suggests>
  </autotools>

  <autotools id="yelp">
    <branch/>
    <dependencies>
820
      <dep package="intltool"/>
821 822 823 824 825 826 827 828 829 830 831 832 833 834
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="libxml2"/>
      <dep package="libxslt"/>
      <dep package="WebKit"/>
      <dep package="yelp-xsl"/>
    </dependencies>
  </autotools>

<!-- Core Extras -->

  <autotools id="gnome-backgrounds">
    <branch/>
    <dependencies>
835
      <dep package="intltool"/>
836 837 838 839 840 841 842 843 844 845 846 847 848 849 850 851 852 853 854
      <dep package="glib"/>
    </dependencies>
  </autotools>

  <autotools id="gnome-user-share">
    <branch/>
    <dependencies>
      <dep package="avahi"/>
      <dep package="gtk+"/>
      <dep package="libnotify"/>
      <dep package="gconf"/>
      <dep package="gnome-bluetooth"/>
      <dep package="nautilus"/>
    </dependencies>
  </autotools>

  <autotools id="vino">
    <branch/>
    <dependencies>
855
      <dep package="intltool"/>
856 857 858 859 860 861 862 863 864 865 866 867 868 869 870 871 872 873 874 875 876 877 878 879 880 881 882 883
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="libsoup"/>
    </dependencies>
    <suggests>
      <dep package="avahi"/>
      <dep package="gnutls"/>
      <dep package="libgcrypt"/>
      <dep package="libgnome-keyring"/>
      <dep package="libnotify"/>
      <dep package="NetworkManager"/>
      <dep package="telepathy-glib"/>
    </suggests>
  </autotools>


<!-- Core OS Services -->

  <autotools id="accountsservice" autogenargs="--with-systemdsystemunitdir=no">
    <branch repo="git.freedesktop.org" module="accountsservice"/>
    <dependencies>
      <dep package="dbus-glib"/>
      <dep package="gobject-introspection"/>
    </dependencies>
  </autotools>

  <!-- explicit disabling of qt3 and qt4 can be removed once avahi
       correctly detects what is available. -->
884
  <autotools id="avahi" version="0.6.31" autogenargs="--disable-gtk --enable-gtk3 --enable-introspection=no --disable-qt3 --disable-qt4 --disable-mono --disable-monodoc --disable-manpages --disable-python --enable-compat-howl --enable-compat-libdns_sd --with-systemdsystemunitdir=no">
885
    <pkg-config>avahi-ui-gtk3.pc</pkg-config>
886 887 888
    <branch repo="avahi.org" module="avahi-0.6.31.tar.gz" version="0.6.31"
            hash="sha256:8372719b24e2dd75de6f59bb1315e600db4fd092805bd1201ed0cb651a2dab48"
            md5sum="2f22745b8f7368ad5a0a3fddac343f2d" size="1268686"/>
889 890 891 892
    <dependencies>
      <dep package="gtk+"/>
      <dep package="libdaemon"/>
    </dependencies>
893
  </autotools>
894 895 896 897 898

  <!-- hack around the lack of autogen.sh; bootstrap-configure doesn't
       quite work since it doesn't pass arguments to configure
    --> 
  <autotools id="bluez" autogenargs="--enable-udevrules=no">
899
    <pkg-config>bluez.pc</pkg-config>
900 901 902 903 904 905 906 907 908 909 910 911 912 913 914 915 916 917 918 919 920 921 922 923 924 925 926 927 928 929 930 931 932
    <branch repo="kernel.org" module="pub/linux/bluetooth/bluez-4.87.tar.gz" version="4.87"
            hash="sha256:86afb988935e5385fb22ea0893f269f870d6f78b18aaccea6d4d0e253e2f241b"
            md5sum="8e615a4e3a05e3b44259e8c51881d48d" size="1114526"/>
    <dependencies>
    </dependencies>
  </autotools>

  <autotools id="ConsoleKit">
    <branch repo="git.freedesktop.org" module="ConsoleKit"/>
    <dependencies>
      <dep package="dbus-glib"/>
    </dependencies>
  </autotools>

  <autotools id="dbus" supports-non-srcdir-builds="no" autogenargs="--with-systemdsystemunitdir=no">
    <pkg-config>dbus-1.pc</pkg-config>
    <branch module="dbus/dbus-1.4.0.tar.gz" version="1.4.0"
	    repo="dbus"
	    hash="sha256:c96d2f86d40e158e2bf405925a0a42cce0533a8466098e2f2238aa1614926652"
	    md5sum="f59618b18d2fb2bd1fce9e1c5a2a3282"
	    size="1800347">
    </branch>
    <dependencies>
      <dep package="expat"/>
      <dep package="glib"/>
    </dependencies>
  </autotools>

  <autotools id="gdm">
    <branch/>
    <dependencies>
      <dep package="accountsservice"/>
      <dep package="dbus-glib"/>
933
      <dep package="fontconfig"/>
934
      <dep package="gconf"/>
935
      <dep package="glib"/>
936
      <dep package="gtk+"/>
937
      <dep package="intltool"/>
938 939
      <dep package="libcanberra"/>
      <dep package="nss"/>
940
    </dependencies>
941 942 943 944
    <suggest>
      <dep package="libxklavier"/>
      <dep package="upower"/>
    </suggest>
945 946 947
  </autotools>

  <autotools id="NetworkManager"
948
             autogenargs="--with-udev-dir=${libdir}/udev --with-systemdsystemunitdir=no --with-crypto=gnutls --disable-wimax --disable-more-warnings">
949 950 951 952 953 954 955 956 957 958 959 960 961 962
    <branch repo="git.freedesktop.org"
	    module="NetworkManager/NetworkManager.git" checkoutdir="NetworkManager"/>
    <dependencies>
      <dep package="libnl"/>
      <dep package="glib"/>
      <dep package="dbus-glib"/>
      <dep package="libgcrypt"/>
      <dep package="gtk-doc"/>
      <dep package="polkit"/>
      <dep package="gudev"/>
      <dep package="gnutls"/>
    </dependencies>
  </autotools>

963
  <autotools id="PackageKit" autogenargs="--disable-tests --disable-qt --disable-browser-plugin" makeargs="CFLAGS=-Wno-error">
964 965 966 967 968 969 970 971 972 973 974 975 976 977 978 979 980 981 982 983
    <branch repo="packagekit.gitorious.org" checkoutdir="PackageKit" module="packagekit.git"/>
    <dependencies>
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="dbus"/>
      <dep package="dbus-glib"/>
    </dependencies>
    <suggests>
      <dep package="gudev"/>
      <dep package="NetworkManager"/>
      <dep package="polkit"/>
    </suggests>
  </autotools>

  <autotools id="polkit">
    <branch repo="git.freedesktop.org" checkoutdir="polkit" module="PolicyKit"/>
    <dependencies>
      <dep package="glib"/>
      <dep package="gobject-introspection"/>
      <dep package="expat"/>
984
      <dep package="intltool"/>
985 986 987
    </dependencies>
  </autotools>

988
  <autotools id="upower" autogenargs="--enable-strict=no">
989 990 991 992 993 994 995 996 997 998 999 1000 1001 1002 1003 1004 1005 1006 1007
    <branch repo="git.freedesktop.org" />
    <dependencies>
      <dep package="polkit"/>
      <dep package="dbus-glib"/>
      <dep package="gobject-introspection"/>
    </dependencies>
    <suggests>
      <dep package="gudev"/>
    </suggests>
  </autotools>


<!-- Meta Modules -->

  <!-- The Core GNOME Utilities: Only unbranded, GNOME integrated
       basic functionality utilities allowed
  -->
  <metamodule id="meta-gnome-core-utilities">
    <dependencies>
1008
      <dep package="baobab"/>
1009 1010 1011 1012 1013 1014 1015
      <dep package="brasero"/>
      <dep package="empathy"/>
      <dep package="epiphany"/>
      <dep package="eog"/>
      <dep package="evince"/>
      <dep package="gcalctool"/>
      <dep package="gnome-contacts"/>
1016
      <dep package="gnome-dictionary"/>
1017
      <dep package="gnome-disk-utility"/>
1018 1019 1020 1021
      <dep package="gnome-font-viewer"/>
      <dep package="gnome-screenshot"/>
      <dep package="gnome-search-tool"/>
      <dep package="gnome-system-log"/>
1022 1023 1024 1025 1026 1027 1028 1029 1030 1031 1032 1033 1034 1035 1036 1037 1038 1039 1040 1041 1042 1043 1044 1045 1046 1047 1048 1049 1050 1051 1052 1053 1054 1055 1056 1057 1058 1059 1060 1061 1062 1063 1064 1065 1066 1067 1068 1069 1070 1071 1072 1073 1074 1075 1076 1077 1078 1079 1080 1081 1082 1083 1084 1085 1086 1087 1088 1089 1090 1091 1092 1093 1094 1095 1096 1097 1098 1099 1100 1101 1102 1103 1104 1105 1106 1107 1108 1109 1110 1111 1112 1113 1114 1115 1116 1117 1118 1119 1120 1121 1122 1123 1124 1125 1126 1127 1128 1129 1130 1131 1132 1133 1134 1135 1136 1137 1138 1139 1140 1141 1142 1143 1144 1145 1146 1147 1148 1149 1150 1151 1152 1153 1154 1155 1156 1157 1158 1159 1160
      <dep package="gnome-system-monitor"/>
      <dep package="gnome-terminal"/>
      <dep package="gucharmap"/>
      <dep package="nautilus"/>
      <dep package="sushi"/>
      <dep package="yelp"/>
    </dependencies>
  </metamodule>

  <!-- The Core GNOME UX Shell: Only integrated session services,
       data, and core UI allowed
  -->
  <metamodule id="meta-gnome-core-shell">
    <dependencies>
      <dep package="dconf"/>
      <dep package="evolution-data-server"/>
      <dep package="gnome-bluetooth"/>
      <dep package="gnome-control-center"/>
      <dep package="gnome-icon-theme"/>
      <dep package="gnome-icon-theme-symbolic"/>
      <dep package="gnome-icon-theme-extras"/>
      <dep package="gnome-keyring"/>
      <dep package="gnome-menus"/>
      <dep package="gnome-online-accounts"/>
      <dep package="gnome-packagekit"/>
      <dep package="gnome-screensaver"/>
      <dep package="gnome-session"/>
      <dep package="gnome-settings-daemon"/>
      <dep package="gnome-shell"/>
      <dep package="gnome-themes-standard"/>
      <dep package="gsettings-desktop-schemas"/>
      <dep package="gvfs"/>
      <dep package="glib-networking"/>
      <dep package="mousetweaks"/>
      <dep package="mutter"/>
      <dep package="network-manager-applet"/>
      <dep package="pulseaudio"/>
      <dep package="telepathy-mission-control"/>
    </dependencies>
  </metamodule>

  <metamodule id="meta-gnome-core-extras">
    <dependencies>
      <dep package="gnome-backgrounds"/>
      <dep package="gnome-user-share"/>
      <dep package="vino"/>
      <dep package="gnome-user-docs"/>
    </dependencies>
  </metamodule>

  <!-- The Core GNOME Fallback UX: Provides a non composited
       fallback experience for incapable hardware
  -->
  <metamodule id="meta-gnome-core-shell-fallback">
    <dependencies>
      <dep package="gnome-panel"/>
      <dep package="metacity"/>
      <dep package="notification-daemon"/>
      <!-- workaround to ensure that dbus-python is around for
           glib tests
      -->
      <dep package="dbus-python"/>
    </dependencies>
    <suggests>
      <dep package="polkit-gnome"/>
    </suggests>
  </metamodule>

  <!-- The Core GNOME OS Services: Only OS System services required to
       provide the Core GNOME UX
  -->
  <metamodule id="meta-gnome-core-os-services">
    <dependencies>
      <dep package="accountsservice"/>
      <dep package="avahi"/>
      <dep package="bluez"/>
      <dep package="ConsoleKit"/>
      <dep package="dbus"/>
      <dep package="gdm"/>
      <dep package="NetworkManager"/>
      <dep package="PackageKit"/>
      <dep package="polkit"/>
      <dep package="upower"/>
      <!-- <dep package="cups"/> -->
      <!-- <dep package="udisks"/> -->
      <!-- <dep package="systemd"/> -->
      <!-- <dep package="xorg-x11-server"/> -->
      <!-- <dep package="plymouth"/> -->
    </dependencies>
  </metamodule>

  <!-- The entirety of the Core GNOME UX, including fallback and utilities
  -->
  <metamodule id="meta-gnome-core">
    <dependencies>
      <dep package="meta-gnome-core-shell"/>
      <dep package="meta-gnome-core-extras"/>
      <dep package="meta-gnome-core-utilities"/>
      <dep package="meta-gnome-core-shell-fallback"/>
    </dependencies>
  </metamodule>

  <!-- Platform metamodule -->
  <metamodule id="meta-gnome-devel-platform">
    <dependencies>
      <dep package="atk"/>
      <dep package="at-spi2-core"/>
      <dep package="at-spi2-atk"/>
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="pango"/>
    </dependencies>
  </metamodule>

  <!-- Extended platform metamodule -->
  <metamodule id="meta-gnome-extended-devel-platform">
    <dependencies>
      <!-- the platform -->
      <dep package="meta-gnome-devel-platform"/>
      <!-- and more modules -->
      <dep package="evolution-data-server"/>
      <dep package="gstreamer"/>
      <dep package="libnotify"/>
      <dep package="libpeas"/>
      <dep package="NetworkManager"/>
      <dep package="PackageKit"/>
      <dep package="polkit"/>
      <dep package="telepathy-glib"/>
      <dep package="upower"/>
      <dep package="WebKit"/>
      <!-- and bindings -->
      <dep package="pygobject"/>
      <dep package="gtkmm"/>
      <dep package="java-gnome"/>
      <dep package="seed"/>
    </dependencies>
  </metamodule>

</moduleset>