• Ondrej Holy's avatar
    smbbrowse: Force NT1 protocol version for workgroup support · 6c8bc39f
    Ondrej Holy authored
    "Windows Network" doesn't work with recent samba versions, because
    "client max protocol" has been changed from NT1 to SMB3 recently.
    NT1 is mandatory for workgroup support. Let's force NT1 using the
    newly added smbc_setOptionProtocols API if available. But force this
    only when neither hostname, nor IP address is used. This among others
    prevents complete breakage if NT1 is disabled on server. Use GResolver
    to implement this heuristic.
    
    https://bugzilla.gnome.org/show_bug.cgi?id=780958
    6c8bc39f