Commit 43388a71 authored by Christian Hergert's avatar Christian Hergert

version: use 4.90 for 5.0 version numbers

This ensures that we don't get internal warnings and so that we can
accurately set version numbers on functions.
parent 7035d3ed
......@@ -233,7 +233,7 @@ G_BEGIN_DECLS
*
* Since: 5.0
*/
#define GTK_SOURCE_VERSION_5_0 (G_ENCODE_VERSION (5, 0))
#define GTK_SOURCE_VERSION_5_0 (G_ENCODE_VERSION (4, 90))
/* Define GTK_SOURCE_VERSION_CUR_STABLE */
#ifndef __GTK_DOC_IGNORE__
......@@ -570,7 +570,7 @@ G_BEGIN_DECLS
#ifndef __GTK_DOC_IGNORE__
#if GTK_SOURCE_VERSION_MAX_ALLOWED < GTK_SOURCE_VERSION_5_0
#define GTK_SOURCE_AVAILABLE_IN_5_0 G_UNAVAILABLE(5, 0) _GTK_SOURCE_EXTERN
#define GTK_SOURCE_AVAILABLE_IN_5_0 G_UNAVAILABLE(4, 90) _GTK_SOURCE_EXTERN
#else
#define GTK_SOURCE_AVAILABLE_IN_5_0 _GTK_SOURCE_EXTERN
#endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment